Just got "Your browser is not supported" from icloud.com

Description of the issue: iCloud.com reloaded itself but came back with “your browser is not supported”

Exact URL of the website in question: https://www.icloud.com/

Did the issue present with default Shields settings? yes

Does the site function as expected when Shields are turned off? No

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): no

Does the site work as expected when using Chrome? yes

Brave version (check About Brave): 1.28.105


Thank you for reaching out to us.
Before we start troubleshooting, can you please update your browser to the latest build (v1.29.81 at the time of writing this) and see if you still have the same issue?

Thank you for looking into this.

I just upgraded to 1.29.81 and I still see the same message that iCloud is unsupported. I’ve also tried this on a second computer, fwiw.

I suspected this must have happend a LOT today?
But maybe just me. If this isn’t widely reported, I’ll fish around for what might have gone wrong. I do have various extensions.

i have the probleme with icloud.com too and i’m on the last version (v1.29.81)

Thank you both for the information. Taking a look at a few things now, will reply here shortly.

I have this problem and am on 1.29.81. iCloud works with Safari and Firefox on my system (iMac, current macOS).

Yeah it looks like this is happening across the board. I’ve opened the following issue for the developers to review/address here:

Thank you all for reporting, hope to have this fixed asap.


lol yeah i just got the issue too thanks for being so fast with it good luck wityh the fix


Same here: updated brave to the latest version but still no go with icloud.

Same here, latest version of Brave. iCloud webmail worked this morning, now showing the same error message as those above.

Looks like we found a fix for the issue and it has been merged – please allow ~24 - 48 hrs for the changes to take effect.


Updating one more time here – looks like we went ahead and updated the Adblock component early please try relaunching your browser and/or going to brave://components and update the Brave Ad Block Updater component:

Just tested on my end and am able to visit icloud.com now without issue using default Shields settings.


OK. This worked for one of my computers! Whatever it is, I think we’re good. Thanks!

Please help - I’ve updated Brave but the Brave Ad Block Updater will not update (it’s at Version: 1.0.1070). iCloud still inaccessible!

Same here. V 1.0.1070 but icloud still inaccessible.

This worked for me. Thank you…

Please help - I’ve updated Brave but the Brave Ad Block Updater will not update (it’s at Version: 1.0.1070). iCloud still inaccessible!

Until Brave’s component updater updates ad block filters, do the following:

  1. Open brave://adblock via the address bar.
  2. Type icloud.com##+js(aopw, navigator.brave) in the Custom Filters textbox at the bottom of the page.
  3. Refresh the icloud.com page.

This is the fix you’re waiting for, it just takes time to get filter lists updated.

I checked in a fresh user profile, there was no need to enter the filter manually via brave://adblock. Check if clearing cache resolves the issue automatically.

Fixed now for me, thank you.