Icloud having issues on Chromium

@Mattches not sure if you can look into this on your end. But on Brave, Brave Nightly, Chrome, and Edge I’m getting the message as seen below when I try to go to icloud.com

image

I contacted Apple support and they don’t see any issues on their end. If I go to icloud.com on Brave using my iPhone, it loads with no issues. I asked support to relay the issue to Apple on their end, but if it’s indeed a Chromium issue, not sure where it would have to be resolved.

Again, I’ve tested on Chrome, Edge, Brave Release, and Brave Nightly. All with the same problem. I’ve also tried to restart my computer, tested on Private window, etc all of which had no success. All other sites and content allow me to login and access with no problems, it’s just something going on with icloud.

And if I click on the Support button it brings me to https://www.apple.com/support/systemstatus/ which shows everything is up on their side.

Anyway, I’m tackling this from two sides. Never can comprehend how to share issues directly with Chromium, but would be awesome if you can help get it to their teams, see if anyone on Brave side can figure it out, or at the very least to confirm it’s happening on a wider range than just my device(s).

Thanks!

NOTE

It doesn’t even get me to the sign in page. It just automatically loads like this. And no, clearing cookies doesn’t matter.

Yeah can inform the team but it does seem like it’s a Chromium issue. Will let you know what I find out, thank you for reporting.

1 Like

@Mattches did I have a misunderstanding here? Did you test this out yourself and experience the same problem?

Asking as I know I have open tickets on it for Chromium and Brave. In Chromium recent response, they mentioned might be a local network issue and not a browser problem. Just trying to make sure whether it was replicated elsewhere or if it really might just be something on my end?

Commenting on https://github.com/brave/brave-browser/issues/32594

I checked Brave Beta yesterday, was able to login. Just checked now using Nightly instead, also able to login. All using 2FA, Clicking on Allow then entering the 6 digit code.

Not using a VPN or secure DNS?

Negative. Nothing like that. Know I tagged in Mattches as partly thought he was saying he confirmed it when said, “it does seem like it’s a Chromium issue.” But seems perhaps I read too much into that.

Btw, @fanboynz, not sure if you’re tracking also but I shared Chromium bug report as well. They had me share info from chrome://net-export. So if that would be of any help to you, that’s up over in replies at https://bugs.chromium.org/p/chromium/issues/detail?id=1475840

Had been working with no issue, then out of nowhere unable to get that icloud login. Like I said, it’s happening on Chrome, Edge, and Brave.

Issue has been happening for a couple weeks. Actually just had to replace my modem the other day, so shouldn’t be modem related as was happening before and after new equipment. No VPN, no antivirus, no firewall, etc. Happened for me on Release and Nightly. Tried with and without Shields, removed extensions, etc. Kind of been trying to do as much troubleshooting steps here as I can think of.

I even did a continuous traceroute by using WinMTR and seems I’m not having any big packet losses or delays when I’ve checked to various sites. I have no clue what the heck would be causing problems.

And I actually just created a brand new Windows user profile on my PC just to see if it could have been something there, but even with everything there on default, it had the same issue.

That said, going to my old Samsung Galaxy S9 which is only able to run on my wifi, it was able to connect with no issues. So I am at a loss here of what might be happening.

@fanboynz and @Mattches in all my testing, I finally decided to do Private with Tor out of curiosity. Doing this allowed the page to pull up. But if I try accessing on just Private or normal browser on any Chromium based browser, it won’t load.

Any idea on what I could/should be looking at here?

EDIT

Also want to note I just tried completely resetting all my network settings, which also uninstalled and then installed new drivers originally made it appear like it would work, but then when I went to sign in, it hit me with the network error again.

@Saoiray,
Sorry for leaving you hanging here.
So I went ahead and tested on my end — looks like signing into iCloud works for me in Brave on my macOS and on Windows 10. I was also able to sign in via Chrome when testing so it looks like this might be related to something on your end, although I’m unclear as to what.

You might try clearing site data for iCloud.com and then testing again. It could also be a Win11 specific issue — try clearing site data and in the interim I’ll try and find someone with a Win11 machine try to reproduce this.

@Mattches yeah, I’m stuck here. I know I messaged Fanboynz and he didn’t really have any ideas what to look at. I sent a DM to Clifton yesterday as well, not sure if he’ll have some feedback. But it’s weird. Not sure what else I can really look at now or do.

Guess I’m just in some oddball situation. Wish I knew what could be changed to make it work. Just stinks that Apple says they can’t/won’t help because it’s happening on Windows and a 3rd party browser. Guess they’ll only help if it’s on Apple products.

And seems Chromium is just letting it sit unless more people report it as an issue. Just two of us reporting it so far.

I’m on Windows 11 Pro. Version 22H2.

  • Doesn’t open on any Chromium browser (Brave, Brave Nightly, Chrome, Edge, Vivaldi)
  • Removed extensions, tried in new profile, and attempted in private windows
  • Shields/adblockers on or off makes no difference.
  • Turning on Secure DNS doesn’t make a difference. I tested with all options in the settings. And having it off doesn’t change anything either.
  • I’ve changed IP, completely replaced the modem, etc but the issue persists
  • I had disabled Windows firewall
  • I don’t use VPN or Proxy
  • I don’t have an antivirus or security program, other than Windows Security (which I had disabled in testing)
  • Clearing cookies does nothing
  • Creating a new OS user changes nothing
  • I tried doing ipconfig /flushdns with no improvement
  • Have varied between my wifi and ethernet, also tried connecting to neighbor’s wifi in case it was my own personal internet
  • Stressing above, but I tried on neighbors wifi, so that’s a different network. It still had the same issues.
  • Performed a network reset to reset all network adapters to factory settings
  • Updated all drivers.
  • Contacted Apple and they said no issues on their end and they can’t help since I’m using Windows and a 3rd party browser. Won’t escalate to an engineer because using Windows
  • Created a Chromium issue, but seems they are pretty much saying “SOCKET_READ_ERROR. It’s not clear what caused the SOCKET_READ_ERROR, but it usually happens on unstable networks.” https://bugs.chromium.org/p/chromium/issues/detail?id=1475840&q=&can=4
  • Used a user agent switcher extension to see if that would matter, but it didn’t change anything.
  • Installed Malwarebytes just in case it picked up on something, but seems I’m good.
  • Created a personal hotspot with my iPhone, still same issue.

As to when and where it works:

  • It opens and works on Firefox (on same computer and profile)
  • When I used Private with Tor on Brave, it worked.
  • If I go to https://appleid.apple.com/ it will load and let me log in. It’s only icloud.com that’s presenting as an issue. (meaning I can’t check my emails)
  • It opens on iPhone (on same wifi network)
  • it opens on my old Samsung Galaxy S9 running Android 10 using the same wifi network as my desktop.
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.