Ios 17.1 constant crashes

Hi, after updating ios to 17.1 last night, brave started to constantly crash every time I try to open it. I tried to reinstall and did a hard reset on iphone but nothing worked. I have been using brave for a long time and never had that issue before. Any help would be greatly appreciated. Thank you

Brave Version: 1.58 (the latest one)
Mobile Device details: Iphone xr

1 Like

@rbrt I just updated my iPhone to be on 17.1 and 1.58. It’s running smoothly with no crashing or anything at this point in time.

If you could, try to follow instructions at iOS crashes: How to share logs as we may be able to see more of what’s going on.

Thanks. We noticed it crashes at launch for some users and paused this release for now.
Can you tell me if you enabled some extra filter lists in your app? or using the default lists

thanks for the reply. I got some logs and can share with Michal through DM.

Thanks for the reply. No, I haven’t activated any specific new filters, was just using the default once. I can share some logs through DM.

feel free to DM me thanks

sorry, unless I’m blind I cant seem to find a way to DM you, can you send me a message and I’ll reply.

1 Like

I have the same issue since updated to iOS 17.1. First I was no longer able to save YouTube videos to playlists, so I reinstalled the browser. Now every time I add some content filter lists it crashes immediately and I have to reinstall the browser each time until I figured not to enable two filters: AdGuard Russian and BitBlock filter for Russian websites. If I leave these two off Brave doesn’t crash, however playlists still don’t work.


I just started getting crash on open constantly yesterday evening. Nothing new changed, no new tabs or settings changes.

From looking here I disabled all my content filters and it has stopped crashing, so I’m 100% sure that’s the cause.

Here is a screenshot of the filters I think I had enabled at the time.

I will see if i can DM a crash log.

Can’t see how to DM a crash report sorry. Any tips?

Incidentally, these crash reports should already appear for the devs in Xcode assuming users have enabled sharing crash reports automatically (I have).

Seems like the crash is happening retrieving meta data?

@onimitch try disabling EasyList Cookie and see if it works. Some sites have been having issues with it causing to crash.

Created an acct to reply this. Exact same problem. Constant crashing on starting up the app with no tab open.

Thanks a lot for pointing to the content filter. Tested, and it’s probably the “Adguard Japanese filters” that causing the crashes. Disabled this specific one solved my problem. Also tested “Easylist Cookie” and “Fanboy’s Mobile Notifications” by only toggling one of them, neither are the causes.

1 Like

Good to know that. Only reason mentioning is had seen it causing Brave to crash when going to and then today someone shared how it’s causing to crash when going to So filters are randomly causing issues depending on websites.

Can you advise if it’s just crashing on a particular site(s), @maouaries?

Hi @Saoiray , in my case, it’s not related to any sites. In fact, this only happens when there’s no tab opening. Tested again, happens on any sites including blank tabs.

Since it seems most related to Japanese-speaking users, you can find the same report here: アプリを起動するとクラッシュする There are more details in these posts.


Same issue here, 2 hours ago I just updated my IOS to 17.1 and Brave app to 1.58, it started crashing every time I opened it and now I can’t use it anymore. And it’s not related to which site or number of tabs mentioned above.

I faced the same issue, but it got resolved for me after I disabled “Adguard Japanese Filters”. Hope this of some help.


Can anyone spot which rule in AdGuard Japanese filter is causing the issue? I checked recent commits but have no idea tbh, it must be something very specific to Brave on iOS, and should be diffferent than the ELC issue caused by mixed quotes. I’m a maintainer of AdGuard Japanese.

Fix is coming on iOS this week. Version number 1.58.2

I am having the exact same issue. I was about to go through the hassle of completely deleting the app, but I am hoping removing my content filters will be enough.
Can’t even restore my tabs because it crashes 5+ times in a row, smh. No big deal though.

The fix is out, please update to 1.58.2 by going to the App Store manually. Sorry for that

1 Like