Inverted Colors on browser Desktop

The colors of my Brave browser are inverted, this effects every website. I originally added an extension for this “night” effect but after removal it never properly removed itself.
It happens whenever brave is open, even after reinstall

However any webpage is normally supposed to look is the expected result after removing the extension.

[Version 1.15.72 Chromium: 86.0.4240.75

I’m assuming the extension was never removed even though it doesn’t show under my extensions; however, there may be a setting for brave dark mode that I clicked on and can’t find again(if there is such a thing).

1 Like

@DigitalDodo,
So if I understand correctly, you had an extension, used it, then subsequently removed it, but even after removal, the effects of the extension persists – is that correct?

If so, a couple easy tests here might be:

  1. As you said, go to Settings --> Appearance --> Brave Colors and change the setting and see if this has any effect.
  2. Try creating/launching a new browser profile (Menu --> Create new profile)-- if it was an extension, then the extension (and it’s associated data) shouldn’t persist across sessions. We can further confirm that the extension or it’s lingering data is causing the issue if the new profile displays as intended (normal colors).

Neither options worked.

@DigitalDodo,
Can you tell me the name of the extension you downloaded and then removed that seems to have caused this? Also, do you have any other extensions running at this time?

I mentioned extension, I meant theme sorry. The theme I had added at the time was “Just black” Offered by the chrome team. My other extensions are only AdBlock and Honey.

Still have not been able to solve the issue.

We have to be clear what we’re referring to, because there’s two different “dark effects” that can be applied for a browser

a) the “theme” of the browser’s components, such as the menu bar, the bookmarks bar, status bar, among other components.

b) the visual content of webpages that are rendered. Normally, webpages have a white background, with black text. If we enable “dark mode” for web content, then the webpage is inverted, ie, black background with white text.

So, which is your issue, the dark “theme” or “dark content”?? Or both??

Notice my screenshot … I have both enabled (plus my phone is in dark mode)

From the two options, I’d say both. Here is an image of the problem I see, I ignored the issue over the summer holiday because I had nothing to submit and never found it to be a massive issue, but as a University student not being able to see the original colors of what I’m submitting isn’t ideal…

There is supposed to be black text on this slide.
I love the dark theme on websites, however I dislike the altered colors of certain content, some websites have issues where it’s already dark-themed and becomes blinding due to the inverted colors which is against the point of “dark theme”. I assume the issue started with the extension - by all means please correct me if you understand the problem. :slight_smile:

Still looking for a solution.

@Mattches
I’ve searched around and still haven’t found a solution.

Hi there - Brave has the Light/Dark theme, as you’ve found: brave://settings/appearance

As of Chromium 76 websites can query if you’re using dark mode:

When I visit sheets or Google docs with dark mode enabled, things look OK (it seems to be light mode in Google docs). You’ve already shared you don’t have any extensions like Google Docs Dark Mode installed, so that’s good:

What happens if you change the browser back to to Light mode? Does Google Docs / slides pick that up?

@clifton
If I switch off dark mode on brave, and go back to light mode. Nothing really changes other than the search bar. Black text is still inverted to white in google sheets and other such websites.

OK interesting- sounds like the theme is what broke you… but you’ve already uninstalled that. Are you on Linux? I’m curious if you have your OS set as dark mode (and if changing that makes a difference)

You might try going to brave://flags/ and then clicking Reset all in the top right. If that doesn’t work, then let’s visit brave://version and you can share the part under Command Line with me (in a private message, preferably - in case there is anything identifying in there)

Sorry I don’t have anything definitive - hope this helps narrow things down a bit

Maybe if you go to flags?
Search for brave://flags/ or chrome://flags and you could something like this:


If you can see there, is an option called Force Dark Mode for Web Contents. Try put it on default or disabled. (I put it on enabled manually and I love it :heart: Cause I use messenger on browser and it is complete black and it is awesome.)
I hope that work…I mean maybe that extension did this.
Let me know if that solved your problem.
Or that extension has light mode too. Have you tried to reinstall that and switch back to light mode? I only think…I have never installed that enxtension :wink:

2 Likes

The issue was the flags forced dark mode, thank you so much! Is there any dark-mode that is recommended to be used that doesn’t invert colors like the forced dark mode did?

1 Like

perfect! Super glad you found it :slight_smile: Thanks for the assist, @Andrei.T

@DigitalDodo I think you can give this extension a shot - it’s meant to give Google docs/slides/sheets a dark mode:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.