Intermittent Brave issue on washingtonpost.com

On the washingtonpost.com home page, there is a “Sections” button at the upper left. Clicking that opens a menu … most of the time. About 1/5 times has no effect (the menu is not displayed). Refreshing the page usually corrects this, but today it did not. Had to close and reopen Brave to fix

Windows 10-64 v2004 (19041.928)
[Version 1.23.75 Chromium: 90.0.4430.93 (Official Build) (64-bit) ] (https://brave.com/latest/)

I tried it out, it seemed to work , but maybe it could be related to the shields? Have you tried turning off the Brave Shields when visiting that site? A certain bill pay site I use nothing worked trying to login and then I turned off shields and that worked. Not the same, but just saying, it could be something to do with the shields maybe?

1 Like

Works on my machine!” (said every developer ever). In all seriousness, though – appears to work fine on my end, could it be an underlying network issue (was this occurring on WiFi or mobile data)? It’s not leaping out at me right now, but I thought there was a button (possibly somewhere under Brave Shields) that would allow you to submit broken websites to the Brave dev team(s). Sorry for the lack of concise information or actionable items here, unfortunately I only have speculation to offer.

Brave Browser Version 1.23.75 Chromium: 90.0.4430.93 (Official Build) (64-bit) on Win10 Pro v20H2 OS Build 19042.964

1 Like

My first suggestion would be to not use a rag.

1 Like

OK, the next time it happens I’ll turn off the shields and see if that corrects the issue. Again, it’s intermittent, so I can’t say exactly when that will be, but I’ll post any results. Thanks

Yeah hopefully that works. I have never had an issue using Brave for months yet where I needed to turn off shields. So I kind of forgot that was a thing. But when I tried it logging in to pay a bill, then that seemed to work for me.

I had a similar issue with another site, the window would freeze and slow me down, it only happened at that site.

Unlike you, I had shields off, after I switched it on it never happened again, the website was running a ton of scripts and that caused my window to slow down. The Washington Post is running a fairly amount of adverts and auto playing videos, I think if you switch off shields, it might slow you down.

I would open Windows task manager ( Ctrl + Shift + Esc keyboard shortcut), click on the Performance tab and look at your CPU & Memory load while you are on the website that is causing you problems, if it is low, then you can rule an issue with computer resources.