Microsoft Teams not working

Description of the issue: Microsoft Teams web version doesn’t seem to work on my laptop. I can enter calls, but can’t hear the other person and can’t see shared content. All that appears is the white ring telling me that the other person is speaking and when the other person shares his screen, I only see a black screen.

I’ve tried using the iOS Teams app and teams web version on Chrome, and it works there as expected. So I believe that the issue is with Brave. I’ve tried disabling sheilds and extensions and reloading the site each time, but it still doesn’t work. I have been facing this issue since 11th December 2020, before which everything was fine.

A similar issue was reported here: https://github.com/brave/brave-browser/issues/9510. My current issue is is his half-resolved issue.

Steps to Reproduce:

  1. Go to teams.microsoft.com and allow the necessary cookies the first time you visit
  2. Try joining a call with video and microphone switched off

Actual Result:


The person on the other end is sharing his screen. Note the glowing ring on the bottom right, signifying that the person is speaking. I can’t hear him though.

Expected result: I should be able to see his screen and hear the person on the other end.

Reproduces how often: Everytime

Operating System and Brave Version: OS: MacOS v10.12.5 (Sierra)
Brave version: Version 1.18.75 Chromium: 87.0.4280.101 (Official Build) (x86_64)

Thanks in advance.

Turning shield off will work. Cannot tell if this is the official solution but this is how I overpass it.

Thanks for the reply. I’ll try doing it again the next time I have a meeting to attend and let you know.

@AlphaBaal,
A few things may be at play here – first, can you confirm that you’ve given Brave permission to user your camera/mic as well as record your screen (this I believe is required for screen share even if you’re not the one sharing)?

You can find this information by going to the MS teams website, clicking the Lock icon in the address bar:
image

If you don’t see the camera/mic options listed here, click Site settings and scroll down to find them. Set them both to Allow (if not already), then reload the page and try again.

Hi. Thanks for the reply. I have those enabled ie. they’re set to “Allow”. I’ve also tried turning Brave shields off and reloading, but it still doesn’t work. There’s nothing I remember changing before it stopped working (sometime around December 11th). I thought it was some automatic Brave update that caused this and was hopeful it’ll be resolved in some time.

@AlphaBaal,
A couple more things to check here:

  1. Can you go to Menu --> Settings --> Extensions --> Hangouts and check to see that this option is toggled “On”? If not, toggle it on and relaunch the browser and check to see if Teams works.
  2. If the above doesn’t work, can you go to teams.microsoft.com, open your Shields panel and ensure that Shields are “UP” and change the Fingerprinting setting to Allow all fingerprinting and see if this resolves the issue:
  3. If nether of the above works, can you try simply creating a new browser profile, logging into teams in the new profile and testing to see if it works there?

Hi. The last solution worked for me. Is there any way to port those specefic settings to my current profile without losing my current profile settings? Thanks.

Edit: The first two did not work for me, if it helps.

@AlphaBaal,
Thank you for testing this for me.
I’d actually prefer, if possible, that we solve the issue in your original profile. The reason the fresh profile is working is very likely an extension causing the error (but you said you tested removing these), or some “bad data” stuck in your profile/browser somewhere.

On your original profile can you try clearing browsing data – first, just try it on the Teams website. Visit teams then Lock icon --> Site settings --> Clear data and you may also want to Reset permissions as well just in case. Make sure the page is refreshed, then grant all the permissions again when asked and see if Teams behaves as intended.

If not, you may need to try clearing all history/browsing data (Menu --> History --> Clear browsing data).

I’ve tried clearing the site data and the history in the last 4 weeks. It doesn’t work inspite of this. I’ve disabled all the extensions and reloaded the site, but it still doesn’t work.
One strange thing I noticed is once I delete the site data (~400MB), the next time I load the site up, it again shows ~400 MB of data whereas I would have expected a number much lower. So I’m not sure if I’m doing it right, although I’ve followed exactly what you’ve told me to do.
PS. In case everything fails, I’m okay with creating a new profile. But is there a way to port my passwords and certain site preferrences to my new profile? Thanks.

@AlphaBaal,
Can you try clearing your browsing data/history/cache? If not and you’d rather just create a new profile, you can export/import your passwords from the Passwords page using the “more options” icon:
image