Impossible to claim rewards

Hello the team,

I’m using Brave on mobile and desktop since long time.

I have resetted my android and now I have to wait 25 BAT to add my uphold wallet, ok no problem.

But last month, after resetting my phone, I clicked on the Claim button and it says after loading some minutes “something went wrong”… I have tried many times and it was the same result.

So I have re-install Brave and lost again my BAT, no problem.

But this morning the Claim button appears and again, “something went wrong”. I can’t claim my BAT.

Please can you help me?

Description of the issue:

How can this issue be reproduced?

  1. Open Brave on Android
  2. Click on “Claim”
  3. the result is “Oups, something went wrong”

**Expected result: My number of BAT may increase

**Brave Version( check About Brave): 1.20.108 chromium 88.0.4324.182

**Mobile Device details Android 10 Mi 9 Build QKQ1.190825.002

**Additional Information:

3 Likes

I’ve had the same problem.

I started using Brave in January. Claim works fine on laptop.

But on Android. If I click on the rewards icon in address bar and click claim, it loads for a few seconds and then I get the message “Oops, something is wrong. Please try again later.”
If I go to the menu, click Brave Rewards and click the claim button, it says “Congrats! You’ve successfully claimed ads rewards. 2.500 Bat” But none show in wallet and if I refresh page, claim button reappears.
This is the second claim period and I now have 2 claim buttons. One for January(2.5 Bat) and one for February(5.25 Bat).

Steps to reproduce:
1: Launch Brave.
2: Click rewards icon in address bar or Brave Rewards in menu.
3: Click claim.

Actual results:
Error message “Oops, something is wrong. Please try again later.” and no Bat added to wallet.
Or message “Congrats! You’ve successfully claimed ads rewards. 2.500 Bat”, but no Bat added to wallet

Expected results:
Bat to be added to wallet.

Reproduced:
Always. Tried in February to collect Januarys and now(March) to collect Februarys.

Brave version: 1.20.108 chromium 88.0.4324.182
Phone: K20 Pro Miui 12.0.4
Android: 10 QKQ1.190825.002

4 Likes

Hello,

Up !

Someone has a solution?

Wow I think that’s a serious problem but they’re not responding… I have the same issue.

Seriously there is no soution???

Same issue. I even upgraded to the latest release from this week.

Brave 1.22.71
Android 10 (QQ2A.200305.003); Pixel 4XL

Same issue here.
Brave 1.22.71
Android 10 (QKQ1.190825.002); Xiaomi Mi 9

@pexuk @tronstin
I claimed my bat this morning. first I checked that the pending rewards were displaying the right amount (currently there’s a bug that show 0.0 or an incorrect amount). and effectively it showed 0.0.

  • force stop the app
  • clear the cache (not the data)

I checked again and everything was good, then claimed the bat and I received them immediately. try that

I tried that a few times, first clearing the cache and then force stop the app, as well as force stop first and then clear cache. No change.

I get the “Oops, Something is wrong, Please try again later” message shown here:

They say if your android device cannot pass safety net check from app store your device isn’t compatible with rewards system, unfortunately many have to find out the hard way as Brave rewards system doesn’t present a problem until you claim

4 Likes

That was it for for me. Thanks, structdjm.

For anyone else with this issue, run the SafetyNet Test and see if it passes. If you get any sort of failure, that would cause this issue. Determine what is causing the test failure and see if you can find/implement a fix.

Once I got a successful SafetyNet Test, the rewards were able to transfer to the Brave wallet.

3 Likes