I can't claim my brave rewards to my BAT wallet

Hello the team,

I’m using Brave on mobile for a lon time.

But on my first rewards, I clicked on the Claim button and it says after loading some minutes “something went wrong”… I have tried many times and it was the same result.

But two months ago the Claim button appears and again, “something went wrong”. I can’t claim my BAT on my Android. If I click on the rewards icon in address bar and click claim, it loads for a few seconds and then I get the message “Oops, something is wrong. Please try again later.”
If I go to the menu, click Brave Rewards and click the claim button, it says “Congrats! You’ve successfully claimed ads rewards. 1.500 Bat” But none show in wallet and if I refresh page, claim button reappears.
This is the second claim period and I now have 3 claim buttons. One for September another for November and December.

Steps to reproduce:
1: Launch Brave.
2: Click rewards icon in address bar or Brave Rewards in menu.
3: Click claim.

Actual results:
Error message “Oops, something is wrong. Please try again later.” and no Bat added to wallet.
Or message “Congrats! You’ve successfully claimed ads rewards. 1.500 Bat”, but no Bat added to wallet

Expected results:
Bat to be added to wallet.

Reproduced:
Always. Tried in September to collect November and now January to collect December.

**Brave Version
Brave 1 .29. 81, Chromium 93. 0. 4577. 82

**Mobile Device details
Android 7 . 1 . 1 ; Build/ NMF26F

What device are you using? Rewards won’t work if you’re rooted, using a custom rom, or using a de-googled device.