Error when using the "claim button"

Briefly describe your issue:

I have not been able to claim the bats won, when using the “claim button”, I get the following error: “Oops, an error has occurred
Please try again later.” This happens to me on all my devices, be it release, beta or nightly. I have only been able to claim in 1 browser.
In a browser the “claim button” no longer appears; I already verified: “brave://rewards-internals/” in “promotions” and the August promotion does not appear, in the other browsers they do appear.

What Operating System and Brave version are you using (Menu --> About Brave)?

Brave 1.43.90
Brave Nightly 1.45.32
Brave Beta 1.44.79

Is your browser wallet currently verified? (yes/no)
No

What date did you verify your wallet?

Have you been able to successfully receive payments in the past?
Yes

Are you using a VPN? (yes/no)
No

Are you eligible for Brave Rewards (see here for list of supported regions)?
Yed
Are you on the list of supported regions when verifying Brave Rewards with a custodial partner (see here for list of supported regions)?
No

Does your device pass the SafteyNet check (Android only)?
Yes

Have you manually turned off Auto-contribute on all of your devices linked to a custodial partner?
Yes

(post deleted by author)

I can ready claim the reward from the browser to which the “claim botton” no longer appeared, I still have 3 browsers to which I have not been able to claim, because it marks an error

1 Like

@Kokokapaku this is something I’ll suggest you submit a support ticket for so they can try to help. In the meanwhile, I’ll also tag @SaltyBanana in case they have ideas on this.

NOTE
In the future, if you have an issue with BAT payments, it’s recommended you just submit a support ticket rather than create a new topic. If you do create a topic, it’s kind of nice to have a ticket number mentioned so they also can pull it up and tie things together. Definitely saves a lot of time and hassle for everyone.

2 Likes

I already have my ticket for 4 days, my ticket is 153860. Thanks for the recommendations.

1 Like

Awesome, by having the ticket then Brave staff can just pull it right up and try to resolve it, just reaching out to you if they need more info or need you to do something. Hopefully, since you’re saying you created the ticket 4 days ago, you’ll be one of the things they review and respond to soon.

That said, I know they have a few issues that the teams are investigating and trying to resolve. Appreciate your patience and the info. Just keep an eye out on your email and for any replies here.

Thanks for the help and sorry for the inconvenience.

Hi @Kokokapaku

Are you running Brave Official, Beta and Nightly all on your Android device?

if I have a huawei tablet that does not have google play services, so I download the apk

I’m going to be curious what SaltyBanana and others tell you, but I think this is going to be your problem. Of course, it also brings up a question. Let me quote you really quick:

Did you actually install this and do SafetyNet? It’s been a while, but I know it was said that Google Play is necessary to pass it. Not to mention, you can’t use things like custom ROM. That might have changed, but I’m just wanting to confirm with you that you did install SafetyNet and passed it.

I have saftynet installed on my phone, where the error occurred that the claim button disappeared and in rewards internals it did not appear, and if I passed the test; I don’t have it installed on my Huawei tablet, I’ll try to install it and check if it passes the test, sorry for the confusion.

1 Like

I already downloaded it and tried it and it does not pass the test

1 Like

Ah, ok. Think this is part of the confusion. Could you advise how many different devices and which OS they are running on? (like Android 9, Android 12, or whatever)

And yeah, if you have it and passed on one device, then at least that should go through. But on others, like on Huawei, it might be an obstacle.

It’s mainly people from Brave that will need to help you on this, but I did want to make sure to clear that up, as it might make a difference in their approach for you.

Yes, thanks, I’ll keep that in mind. I proceed to solve the problem. And I will continue using “Brave”, on my huawei tablet since for me it is an excellent browser.

Thank you and sorry for the problems caused.

Wait, I see you marked solved but it’s not really solved, right? The Huawei might be an issue but we would have to confirm with SaltyBanana. But you said it’s also an issue where you couldn’t claim on your phone, right? If your phone passed, then you should have been able to claim and have it on your device.

I don’t want you saying it’s solved if you’re not getting BAT that you should be getting. And you’re not causing any problems. It’s always good to ask for information and share what you can. We’re just asking questions and getting a clear understanding of the issue so what can be fixed will be fixed. (^_^)

Ok, on my phone the problem is already solved, the claim button reappeared and I was able to claim my bats.

2 Likes

Yay! Okay. Good to clarify. So if solved, keep it checked solved, lol. I just thought you were saying still didn’t get on any device and I wanted to make sure you weren’t missing anything.

And as to the Huawei, once you confirmed it doesn’t pass the test, I know for certain you can’t receive. It’s just a layer of fraud protection they have. Though hopefully they’ll be figuring a way beyond that here in the future.

Thanks for answering everything so we can try to help.

2 Likes

Thank you for your help.

Hi @Kokokapaku apologies for jumping in late here.

Just confirming if your Huawei passed or failed the safetynet test? If it failed that is most likely the issue here why you can’t claim your rewards.
However, if it did pass the safetynet test…we’ll have to take a closer look at the issue.

Update:
After checking your ticket, it appears your issue has been resolved for your other device which you did confirm in this thread.
However, I’ll await confirmation from you if your tablet passes the safetynet.

Thanks!

Hello indeed, on my phone I did pass the test, but on my tablet I did not pass it.