I see only blank browser windows - failed use of brave://flags

Description of the issue:
Brave is my default browser. It is up-to-date. I was frustrated because I could not cause GLOBE to appear in Google Maps - yet it works in Firefox (since Brave is disabled, I’m using Firefox to post here).

At a Google site, a user suggested

  1. going to brave://flags and
  3. ENABLED. This action was supposed to enable GPU-acceleration.
  4. Then, RELAUNCH the Brave browser. That is what I did.

All of the menus seem work, but every browser window is completely blank!!!

I don’t know how to remedy this. I tried downloading a new copy of Brave. That didn’t work.

I would really like to restore it to full operation, and retain my history and passwords.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Launch Brave
  2. the browser window is completely blank except for the iMac 3 colored dots: red. yellow. green.
  3. The pulldown menus from the menubar all seem normal

Actual Result (gifs and screenshots are welcome!):
There is not much to show. Nothing appears in any browser window.

Expected result:
Brave seems to be operating, but it is not showing the contents of the browser windows. I would like to see it restored to full operation.

Reproduces how often:
Every time I open a Brave browser window.

Operating System and Brave Version(See the About Brave page in the main menu):
iMac 24-inch, early 2009
chip: 3.06 GHz Intel Core 2 Duo
memory: 4 GB 1067 MHz DDR3
graphics: ATI RAdeon HD 4850 512 MB

I cannot see ‘About Brave’ – as you know – but I updated Brave just before I caused this problem, and I’ve just downloaded the latest version. So, Brave is current to 2021 March 29.

Additional Information:
Brave is central to my day’s activities. I can live without Globe for Google, but I rely on being able to use Brave. I appreciate help in restoring this software. Thanks

It has been 9 or 10 hours of agony, but I think I may have solved my problem — without really understanding what happened.

I just discovered that Brave would show one page that was not blank, the URL is: brave://flags

Suddenly, there was the page that seemed to be the source of my problem. One option offered was something like: RESTORE DEFAULT SETTINGS. (I don’t recall what was the actual name of the button because it has now vanished; but it was something like that). Figuring that I had nothing to lose, I clicked on the button, and then chose RELAUNCH.

Brave quit and relaunched. There was my old Brave back again. (Google Maps GLOBE is still not working.) So, my problem seems to be solved.

While my problem seems to be resolved, I would still appreciate a cogent explanation of what happened here, and maybe some assurance that I have not done any long time damage to my installation of Brave.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.