"I have a Sync Code" button missing in version 1.20.103

NOTE: Any “one-liner” or topics requesting support or reporting bugs that do not make an effort to include as much of this information as possible will not be responded to. Repeatedly posting as such is grounds for banning._
Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Description of the issue:
When trying to add an additional device to a sync chain, there is no “I have a Sync Code” button in either Brave v 1.20.103 in Kubuntu nor Windows.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Goto Settings
  2. Select Sync
  3. Select “Manage your synced devices”
  4. Marvel at the missing button.

Reproduces how often:
Everytime.

Brave Version(See the About Brave page in the main menu):
Version 1.20.103 Chromium: 88.0.4324.152 (Official Build) (64-bit)

Type of devices currently running on the Sync chain in question:
Three desktops, two windows, one kubuntu 20.10

Additional Information:
Not having this button, makes it impossible to add any new devices to the chain.

Hi @rick.jilocasin, Welcome to Community!
That sounds about right. If it says Manage your synced devices that means the current device is already on a sync chain. Can you try going in / scrolling to find Leave Sync Chain
OR if you’re trying to add a different device to a sync chain then the current device there should be a Add New Device button.
Can you send screenshots so I can how it looks on your end?

Here you can see what it looks like on the from and to machines.
from:

and to:

If I scroll down to the bottom and select the Leave Sync Chain button, it takes me back to the previous screen

Selecting Manage your synced devices just goes back to the previously illustrated to screen. showing the only device on the chain is itself and no way to add it to an existing chain since there is no I have a Sync Code button anywhere to be found.

Thanks.

Based on your screenshots, both devices already on sync chain. Different sync chain (?). The “I’ve sync code” is only available on the setup page.

From https://support.brave.com/hc/en-us/articles/360021218111-How-do-I-set-up-Sync-

image

And what happen if you try to setup the sync again?

1 Like

No matter how many times I hit the Leave Sync Chain button, I am always on a chain consisting of the machine it’s installed on.

  1. Leave Sync Chain
  2. goes to Setup with Manage your synced devices
  3. goes back to from screen shot showing chain consisting of machine browser installed on
  4. Rinse lather, Repeat

@rick.jilocasin
On the device that you want to leave the sync chain on, go to brave://sync-internals/ and clear the sync data.

Sorry, but that didn’t fix the issue.
Here’s what it looked like before I did anything:

and here’s is what it looked like after I pressed DIsable Snyc (Clear Data):

This gave me a I have a Sync Code button back again. Unfortunately when I entered the sync code from my other device this is what the Manage your synced devices looks like:

Nothing is syncing and the View Sync Code is not the Sync Code that I had entered. :confused:
So, while I can get the I have a Sync Code button back, (via your methodology) it doesn’t appear to do what it says on the tin.