Missing sync button (Android)

Trying to sync Brave across two android devices.
One unit has a page with a QR code ready, and instructions to use a button called scan sync code.

However, I’m unable to locate the sync button.
Where can I find it?

**Brave Version 1.19.86

**Note 9, Android 10.

**One UI 2.5

@Ornamental,
You need to have on Device on the chain to start.
Then, on the second device (that is not yet added to the chain), you’ll open Brave and select Menu --> Settings --> Sync --> Scan or enter sync code. Return to the first device and go to the Sync page. Select Add another device and scan the QR code that is shown.

Please take a look at the attached screenshot above.
That’s what I see after going Menu --> Settings --> Sync.
There is no “Scan or enter sync code” there.

@Ornamental,
The two options should be Add new device or Data preferences in the page from your screenshot. Please tap Add new device, specify the type of device you’re adding, then you will be offered the option of scanning a QR code or using the code words to add your second device to the chain.

“Legg til ny enhet” means “Add new device”.
Except for the background being either black or white, the screenshots are pretty much identical apart from the desktop being present on the black background.

So how do I get “Scan or enter sync code” on the unit with the white background?
I tried to work around this by downloading the Brave browser to a laptop, but no success.

I suspected that the sync were depending on no bookmarks present on the other (white) unit, so I deleted the old bookmarks there, but it didn’t change anything.

I’ll try to delete and reinstall Brave on the unit with the white background tomorrow.

The unit with a black background is a newer, but damaged unit, and the white is a older unit I’d like to get the newer bookmarks transfered to.

Being a new user I’m only allowed 4 uploads in one post, so I skipped the screenshots of selecting the type of unit being added.

@Ornamental,
Okay – so the issue is that the QR code isn’t displaying properly, not that the QR code doesn’t exist right? Because that is the correct page. It’s more of a hassle but instead of scanning the QR code, can you try entering the code words instead – simply tap on the tab at the top (Kodeord) to reveal them. I’ll look into the QR code issue in the meantime.

No, I cut the QR code out from the screenshots.
You know, they’re basically passwords that shouldn’t be shared with anyone, so posting them online didn’t seem like a good idea… …Right?

The issue is as I’ve stated several times and provided screenshots for:
There
is
no
button
for
scanning
the
QR
code
.

@Mattches I think Ornamental just removed the QR code for security reasons in the screenshot he sent.
I have the same problem to sync my iPad with my Mac and android Phone. I could sync my android phone with the Mac before but when I try now to add my iPad, it is not working.
I go on add new device on my Mac then on add phone/tablet and it tells me to navigate to Brave Sync in the Settings panel and click the button “Scan Sync Code”. But there is no Scan Sync Code on my iPad in the Sync Settings. Neither a “I have a Sync Code” button.
The only button in the sync settings is Add New Device.
The same problem if I try to set the sync chain from my iPad to the Mac instead of Mac to iPad. There is also no “Scan Sync Code” or I have a Sync Code" button.
Is it just possible to connect one device? It worked with my android phone and Mac. Android phone to iPad also not possible.
Thank you

@Ornamental,
No need for sarcasm.
Allow me to walk you through the steps very, very explicitly. I’ll be syncing my desktop version of Brave and my Android phone :

  1. On desktop, I’ve gone to Menu --> Sync and I see the following page:
    image
  2. I select `Start a new Sync chain.
  3. I’m now asked which device I’d like to Sync to. Well, I have an Android device, so I’ll select Phone/Tablet:
    image
  4. This produces the following message:
    image
  5. Now, using my Android device, I go to Menu --> Settings --> Sync and see this page:
  6. Now – since I already have the QR code ready to go on Desktop, I select Scan or enter sync code, landing me on the following page, where I can use my camera to scan the QR code I have pulled up from step 4:
  7. I now scan said QR code using my Android device. Android device gets added to the chain. Click OK on desktop end and you’ll see a message stating that Sync has started...on the bottom left of the screen. You can then click Manage your Synced devices and change Sync settings.

Can you please tell me where in this process you aren’t able to reach?

@MrJazz82,
This is because the I have a sync code option appears on the device you’re attempting to sync, not one that is already on the chain.

For example, my Android device after the process I laid out above only has Add new device as you describe. What this is saying is "I am a part of a sync chain and I have that chain’s information. Use me to connect more devices to this chain."

However, if I go to my iPad, Windows machine, Linux machine or whatever else that does not yet have an associated Sync chain, you will see the I have a Sync code option appear.

So if I want to add my Windows laptop to the same Sync chain I just created in the process I laid out above, I would:

  1. Go to my Windows laptop (for example)
  2. Open Brave.
  3. Menu --> Sync
  4. I have a sync code
  5. Then, I can or enter code words that are on my Android device, or on the initial desktop device I added to the chain, since they both have the necessary information.

Does this make sense?

I wrote that the issue is the button for scanning the QR code is missing, not that the QR code is missing.
Other than saying “the button for scanning the QR code is missing”, how can I possibly make it more explicitly clear that the issue is that the button for scanning the QR code is missing?

With that out of the way, step 5 is where it goes wrong.
As I wrote in my second post, when I go Menu --> Settings --> Sync, I see this page:

There is no button for Scan or enter sync code there.

@Ornamental,
That device is on the chain already and that page is used to Add new devices to the exiting chain that device is on. So from where you are – assuming that Android device in the image above is the device which has the data that you would like to get onto your other devices – go to your other device(s) you want on the chain, open them, launch Brave, go to Menu --> Sync, then click I have a Sync code on that device.

Now return to the Android device in the image above. Click Add new device and select which type of device you’re adding – if a desktop, code words will display by default, if a mobile device, a QR code displays by default. Scan this code/enter these code words into the new device you are adding to the chain.

Thank you, it’s working now. The problem was also that my iPad already was on its own sync chain. even it was not synced with anything. I just removed my iPad from the sync chain and I was able to connect it afterwards.

1 Like

To further illustrate, continuing from the Sync chain I created above, let’s add my iPad to the same chain.

  1. Launch Brave on my iPad.
  2. Go to Menu --> Sync
  3. Observe the second option:
  4. I select it and get the following:
  5. Now, on my other Android device (I could also do this on my desktop on the chain) I will go to Menu --> Sync --> Add new device

I will now use my iPad camera to scan the QR code (or enter code words) from the device I chose already added to the chain.

These devices are not part of the same chain.
The device with a black background (SM-N960F) has itself and the laptop (DESKTOP-7260V9R) on its chain.
The device with a white background (SM-N950F) only has itself on its chain.
I try to get SM-N950F on the same chain as SM-N960F and DESKTOP-7260V9R.

The device with a black background has the data I would like to get on onto the device with a white background.

Both devices only has the option to add new devices by providing a QR code or code words. It does not have the option of being added by scanning a QR code or entering code words. I cannot click “I have Sync code” because it’s not an avaliable option.

I repeat, your step 5 is where the problem lies.
Menu --> Settings --> Sync
Where you have this:
fb245745183a7f95f56604e7096ccc7733b9d67f_2_202x375

I have this:
Menu --> Settings --> Sync

@Ornamental,
Then you need to remove SM-N950F from the chain it was on previously. Simply tap the trash icon next to the device’s name. It will be removed from the chain, and the next time you go to Menu --> Sync, you’ll see the appropriate page.

1 Like

Wonderful, that did the trick.
Thank you very much!

1 Like