I cannot claim my brave rewards. Claim button not working

It shows my rewards from ads are here, The claim button does not seem to work. Nothing happens when I click on it.

I have the same problem (and 2 other issues with Oct rewards), except there are 2 claim buttons, neither will do anything when clicked.
Using V1.31.88 (desktop, windows), recently connected and verified to Gemini Wallet.

EDIT:
Following the below solution worked for me and solved all my issues. Thanks!

1 Like

I have been having the same problem since last month. I thought it was a glitch that would go away on Nov. 7th when this months reward wasdue, but I’m still hvaing the same problem and now I have two claim buttons that don’t work.

I found another user that had the same problem in another thread and the following solution worked to fix my problem. See picture below.

4 Likes

That worked for me, thanks!

Turning off the option “Hide Brave Rewards Button” in the appearance section in the browser settings immediately worked and I got my past two months of BAT rewards into my Gemini wallet, solving ALL of my issues.

Hi,

Thank you! It worked

While this solution also worked for me, this should certainly be investigated as a bug. It seems that whenever the designers tied the “captcha popup” to the rewards button rather than the rewards page, they didn’t consider that people frequently enable hiding it.

Hi all, welcome to Community :smiley:

Thanks for bringing this issue to our attention. I have made note.

Salty :banana:

1 Like