Unable to click on Claim Rewards

Initially i had an issue dragging the triangle into the right shape as it wouldn’t recognize i did it correctly… NOW, i can’t even get to that step. I click on “CLAIM” but nothing happens… is there an issue?
thanks!

2 Likes

Try to change Zoom from 100% to 75%, it worked for me.

1 Like

Exactly the same problem with me! I was having issues getting the shapes into the right places, then, I assume after the latest update, Claim doesn’t work. When you click on it, nothing happens.

I added a Gemini wallet to solve the problem, I guess in 5 days new rewards will be awarded to my wallet, however previous rewards from the last 3 months are stuck need help ASAP!

Thanks!

The claim button isn’t working for me either. I click it, yet it does absolutely nothing. What @CharlesKlein suggested doesn’t solve it either.

Regarding the dragging the image issue, it does the exact same thing for me half the time! I drag it onto the right thing, it says I did it wrong, I do it again, then it works. It happens like this almost every single time.

Update:
After looking more into it, I found something that allowed me to redeem (it doesn’t fix the claim button not working, but replaces needing to click it). I had to disable the “Hide Brave rewards Button” setting and claim + drag the triangle through that.
Sources:

2 Likes

You are the Person! Thank you a lot for the sources and the solution. It worked. I was able to collect rewards by the URL bar. Simply add the rewards icon and collect via there. Brilliant.

THANK YOU @JJCUBER, your workaround works perfectly! :slight_smile: