Claim button does not work

The claim button I have when I click on the BAT logo does not work.
I can you tell me what to do?

Version 0.61.51 Chromium: 73.0.3683.75 (Offizieller Build) (64-Bit)

Windows 10 64 Bit

1 Like

Try to uninstall and reinstall Brave…

1 Like

Please repost (or edit your original post) to reflect the template and guidelines and we’d be more than happy to assist you.

1 Like

What do you mean by repost my original post? :smiley:
Like that with the version number?

1 Like

@enum,
Just to confirm, do you have Rewards enabled?

2 Likes

Yes, Brave Rewards are enabled.
Unbenannt

2 Likes

And when you hit the “Claim” icon in the Rewards panel nothing happens?
This is an old issue that should have been addressed already IIRC.
Would you mind sharing a short recording of the behavior while I dig around GitHub issues to check the status on this?

5 Likes


Exactly, nothing happens.
1 Like

@enum,
Really appreciate the visual confirmation and additional info. Looking into this right now.

3 Likes

@enum,
I think you may have a corrupted leger_state file. Luckily this is easy to test. Click the “people” icon next to the main menu:
image
And create a new profile – this will generate a new wallet and (subsequently) a new ledger_state file. See if the claim works on this new profile.

1 Like

And what happens with the BAT I got and can’t claim(51.9 BAT for now)?
I have created a new profile now, but the BAT I got can’t be claimed because they are bound to the old profile, or not?

1 Like

@enum,
This was simply to test whether or not your ledger_state file may be corrupted.

In your new profile, does a Claim appear in your Rewards panel and, if so, are you able to click and claim it as intended?

2 Likes

@enum Are you able to claim grants from settings page? Click on Brave Rewards in the hamburger menu, you see claim button in settings page, click on claim button in brave://rewards settings page and see whether you are able to claim grants or not

Thanks!

1 Like

@Mattches
I created a new profile and firstly didn’t have any “claim” button there where it was in the other profile. But later it appeared somehow. Still it didn’t work.
Then I tried out what @gsarvadnya said and somehow now the claim button appeared on brave://rewards and it worked there.

I also had a new update after that, now running:
Version 0.61.52 Chromium: 73.0.3683.86 (Offizieller Build) (64-Bit)

2 Likes

Hello!

@enum you’re quite a lucky guy with the solution that worked for you.

It happens that I’m experiencing exactly the same original issue with
Brave 0.61.52 Chromium: 73.0.3683.86 (Build officiel) (64 bits)
The claim button appearing here:


does absolutely nothing.

And there’s not a single “claim” button in the rewards page:
(sorry, I’ve switched to French just a few minutes ago and, hence the capture of that page is now in French, but the absence of any claim - which probably would read “réclamer” - button is perfectly clear)


Hence @gsarvadnya proposed workaround does not work for me.

If anyone has a clear explanation (using Brave @ work maybe) of this issue, that would be great!

1 Like

@lucp Could you Reload the page brave://rewards page - Sometimes claim button won’t visible in first navigation need to reload the page for 2 - 3 times.

Thanks!

1 Like

Why does this even happen?

@enum One of the reason could be server issue, when server is down or not responding we may get this issue.

1 Like

I’ve been having this issue for months on MacOS High Sierra. Although it says I have a grant waiting for me, the Claim button on the main screen does not respond and there is no option to claim anything on the Rewards page. Brave Rewards are enabled. When I create a second user/person, there is no grant to claim. Brave version 0.62.51 Chromium: 73.0.3683.103 (Official Build) (64-bit). Reloading the page doesn’t work.

Same issue here, unresponsive claim button, nothing showing up on Rewards Page, even after reloading several times.
Already tried adding another Person, notification doesn’t show up there.