HTTP 403 Forbidden error when using the autoupdater to upgrade to Brave version 1.12.114

Description of the issue:

On my HP Pavillion 15-cs3xxx laptop, I’ve been unable to update to the most recent version of Brave since August 20th. The autoupdater continues to throw this message:

“An error occurred while checking for updates: Unable to connect to the Internet. HTTP 403 Forbidden. Please check your proxy configuration. (error code 7: [0x80042193]”

This error continues to appear despite me changing my proxy settings, disabling the VPN entirely, and performing basic network troubleshooting. Said laptop is on Windows 10 Pro version 2004, OS build 19041.450, with the most recent updates installed, both from HP and Microsoft.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. On Windows 10 Pro, open up the Brave browser, and click on the three bar icon to the top right of the screen.
  2. Scroll down and click on the “About Brave” option from the dropdown menu.
  3. On “About Brave” screen, check for updates, and await an answer from the autoupdater. If there are updates, they will be downloaded automatically, and applied.
  4. Restart the browser, and confirm that you have been upgraded to the most recent version.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Autoupdater downloads the most recent version from the server, applies it to the installation after restarting, and the browser is now set to version 1.12.114 (or the most recent version).

Reproduces how often:

Every time after opening the browser and navigating to the “about Brave” page, even after resetting the network, not enabling the VPN, and/or a cold reboot.

Operating System and Brave Version(See the About Brave page in the main menu):

Windows 10 Pro, version 2004, 19041.450
Brave [Version 1.12.112 Chromium: 84.0.4147.125 (Official Build) (64-bit)]

Additional Information:

On my desktop version of Windows 10 Pro, the same version and build, the autoupdater works perfectly fine, and I was able to upgrade to the most recent version without difficulty. The same VPN is used for both computers, and there are no significant differences in terms of each build. Any assistance in helping to resolve this matter would be greatly appreciated. Thank you in advance for your assistance.

Hey there.

I’ve got exactly the same problem. I’ve also tried everything from other topics, like:

  • Kliing brave in Task Manager
  • Running it as administrator
  • Disabling Windows Defender and Kaspersky Internet Security

Nothing seems to be working for me. Every time I get the same error, over and over again:

If I use standalone installer, Brave updates successfully, but I doubt it should work like that…
I’am using Windows 10 Pro (x64), version 2004 with latest updates. I’m also using Opera and Edge and they are updating without any problems.

Hey Patricko, thank you for replying.

I’ve tried flushing my DNS and renewing the IP address, but after opening the application, it now told me that the updater is running, despite no instance of BraveUpdate.exe appearing within Task Manager. It then threw me the same error as before once I refreshed the autoupdater.

I’m not sure what is causing the issue, especially considering that I’ve rolled back my drivers and nothing has changed. :frowning: If you don’t mind me asking, how long have you had this issue?

Just wanted to update this thread. I opened up the browser again, to which the update somehow went through. I’m now on the most recent version, so I’m not sure if flushing my DNS somehow fixed the issue, or if it was an issue on Brave’s end.