How to turn off autocomplete for forms?

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue: I keep getting form suggestions even though I already cleared “Autofill form data” on “Clear Browsing Data”. Since this doesn’t work, I would like to disable autofill/autocomplete everywhere, permanently.

**How can this issue be reproduced? ** Go to settings and try to find an option to disable autocomplete for forms. You won’t find it.

Expected result: No more annoying search/form suggestions within websites

Brave Version( check About Brave): Brave 1.22.71, Chromium 89.0.4389.114

Mobile Device details Huawei P40 Lite

Additional Information:

Here is the problem:

Here are the options under privacy:



No option to turn off autocomplete, only for urls on the url bar and searches in a search engine.