Turn off auto complete on Brave for Android

Is there a way on Android to turn off the autocomplete and top site suggestions? These are basic options present in the desktop version, but I haven’t been able to find them in the Android browser settings. I’m trying out Brave, but anyone standing around while I use my browser seeing my top sites and bookmarks is a deal breaker. I’m also concerned about where this data is stored since clearing my browsing history doesn’t even get rid of them or change them at all. If it’s stored locally, where is the option to delete this data?

The autocomplete preferences on Android are located at the bottom of the Brave shields & privacy page.

SettingsBrave shields & privacy

Thanks. I didn’t notice them but they were already turned off. I tried turning on then off again and relaunching, but still the same. For whatever reason my browser is ignoring these settings. Where is the actual data to delete it? It’s not populating from history. I’ve deleted that multiple times.


Is your issue the same as the one from the Github report below?

I would check if clearing Cookies site data and Cached images and files via SettingsBrave shields & privacyClear browsing data has an impact, make sure you change Time range to All time as well.

Also, are you seeing your top sites and bookmarks as autocomplete suggestions when you start typing, or are they displayed when you click on the URL bar?

No, that isn’t the issue. I get around that by choosing a search engine I don’t actually use, so there are no results to show.

I deleted everything as you suggested. When I tap the address bar on an existing tab, I still get a list of 4 sites and it searches my bookmarks and browsing history as soon as I start typing. Why it still has a browsing history to search and where that data resides is concerning.

If it doesn’t respond to it’s own options and has a mystery file somewhere of my browsing history, should I just uninstall?

Before you uninstall, let someone else take a look at this thread, we could be missing something. I share your opinion that it’s an unusual behavior, you shouldn’t be offered anything when options are disabled and browsing data is empty.

I think I found part of the issue. Clearing the history is not working. If I go to history in settings, the entire browsing history is still there. It seems every entry has to be individually deleted.

That doesn’t explain why it ignores the settings though, and makes the browser unusable if every entry in browsing history has to be deleted one by one.


Could you check whether disabling brave://flags/#brave-ephemeral-storage allows you to clear your browsing data successfully?

Figured out what was happening with the history and cleared it. It still ignores the top site settings.

The browsing data was user error. I didn’t notice the default for clear data was an hour. It worked fine when I changed to all time.

As soon as there was fresh history to access though the bar went back to populating top sites and searching the history.

That’s an interesting issue. Share the exact version of Brave as that might help other Community users assist you.

About info attached.

Am I the only person to encounter this issue with brave ignoring autocomplete settings? If so, I’ll uninstall assuming it simply doesn’t work correctly on my phone.

@mattches @fanboynz @Rethanis also noticed this.The settings are just being ignored.I thought its just me. :face_with_raised_eyebrow:

Never a fix or explanation for this. Now it crashes as soon as it opens on a new phone. Guess this just isn’t a reliable browser.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.