How to stop my Google account from remembering me

windows
#1

Description of the issue:
Launch Brave
Login to my google account (gmail)
Close browser
Reboot
Login to Brave
Launch Gmail
It auto logs me in

Expected result:
I would like Brave to forget me and force me to login to my gmail account again after closing the browser.

Reproduces how often:
Everytime

Operating System and Brave Version(See the About Brave page in the main menu):
Version 0.61.52 Chromium: 73.0.3683.86 (Official Build) (64-bit)
Windows 10

Additional Information:
The scenario which scares me is a system crash.
Bring the laptop in for servicing
They get Windows going again
Some unscrupulous tech launches Brave
Auto logs in to my Google account
Has access to all my Google data

0 Likes

#2

@ronatola,
There are several ways to accomplish this.
Easiest way:

  1. Navigate to Settings --> Passwords – toggle off the Auto-sign in option at the top. Note that this will be reflected across all sites.

Medium way:

  1. Find your Gmail account in this list and remove it
  2. Next time you attempt to login to gmail, when prompted to remember your password information, select “never” from the modal box that appears.
    Now, your gmail credentials will not be saved and you will have to enter them every time to login.
0 Likes

#3

That doesn’t work.
Here are my settings

If I open BRAVE and bring up GMAIL it prompts me for my id and password
Then I close Brave without logging out of Gmail
I then launch Brave and go to Gmail
It auto logs me in

I want it to always ask for my password

0 Likes

#4

@ronatola,
You probably need to clear your cache/cookie data (or at least any associated with accounts.google.com or mail.google.com before the change takes place since this information is already stored/set.
Menu --> History --> Clear Browsing Data and relaunch Brave.
Let me know if this works for you.

0 Likes

#5

Nope.
opened brave
logged out of gmail. cleared everything.


opened brave
logged in to gmail
prompted for loginid and pswd and 2 way verification
closed brave
open brave
go go gmail url
auto logs me in

0 Likes

#6

@ronatola,
When you entered your credentials for gmail, did you elect to Save the password when prompted by the browser? Additionally, after clearing all data, you may have to toggle the Auto Sign-in setting (Settings --> Passwords) to “off” again.

0 Likes

#7

I have the same problem. I would never allow my browser to remember my login credentials (password saving setting off) nor confirmed any website to “remember me” during login as I’ve been quite careful about this. I have done the same steps as you proposed to the other guy.

0 Likes

#8

@ScorpioRed,
What does your list of remembered passwords look like? If it’s blank, Brave is not saving your passwords - it may be that your session is remembered.
Try the following:

  1. Visit the site you’re being auto-signed into and click the “lock” icon on the left side of the address bar
  2. Click Site Settings
  3. Scroll to the very bottom and click Reset Permissions
  4. Now scroll back to the top of the page and click the “back” arrow – this should land you in Content settings
  5. Go to Cookies --> See all cookies and site data
  6. Use the search box and run a search for [site]
  7. Click Remove All Shown to clear any remaining cookie data for the site.
  8. Relaunch Brave and return to the site.

Are you logged in?

0 Likes

#9

I tried doing the RESET PERMISSIONS and then cleared all the cookies

Brave still auto logs me in if I close the browser without logging out from gmail and then I open the browser again and go to any google account website IE gmail;photos;gdrive

Does this work for you Mattches? Does it log you out automatically?

0 Likes

#10

Actually, all i have to do is sign out the first time after flipping the Auto signin switch to “off”:

0 Likes

#11

My password list is completely empty, because I always make sure all of similar features are off right after installing the browser anytime.

I followed all your steps but it did not work for me :frowning: Regarding your last post - I don’t want to elaborate with switching off auto signing followed by logging off, because my auto signing has never been turned on and I want to keep it as it is. Browser is supposed to work how it should be without any annoying walk-around.

I am sorry, but in last 2 weeks Brave gave me so much head ache and I ran in 3 critical bugs (you can search them in the forum: screwed support for a crucial extension, grilling my GPU and this one).

So, instead of taking benefit of a new browser I spent so much time solving issues I have never encountered with my previous Chromium based browser (Iron), which I have to take back for now.

I am pretty sure you have many satisfied users, I wish you good luck and I might give your browser another try sometime to see if things have moved. Thanks!

0 Likes