How to make Yandex the default search engine?

It appears as though there used to be an option to add a search engine in the settings in brave browser. This has since disappeared. There is a section below it where the “Add” button still exists… but it is no longer the “add search engine” button that apparently did exist some time ago.

Moreover, when you click on this add button this screen comes up.


What, that third prompt is asking from you, I have no idea. At any rate, if this is the way to add Yandex as a search engine, it is pretty damn far from obvious, and I would argue that this is not by any means a way to add Yandex as the DEFAULT search engine. Previous results on how to add Yandex show, very clearly, a button whereby you can “add search engine” and the prompts are clear, and it is obvious that you are in fact doing just that.

I reckon this is a deliberate move by brave to limit what you are able to read and not read. I don’t know what this function does, but clearly it is at the very least adding an extra unnecessary step that did not exist in order to more easily use the one remaining (perhaps??) browser that does not inject its world fucking view into the search results. Furthermore, I am a big boy, I can read and discern the information on the screen for myself thank you very much.

If I am incorrect than why did brave intentionally make things more difficult/less clear/worse?

I will be uninstalling brave and using a more bare-bones browser and search engine, I have zero tolerance for this diversity/DEI/censorship/search engine freedom which is permeating every f*cking corner of our lives.

Just add this to the third prompt:

What? What do you mean?

Hello, would you please elaborate on how you mean? Thank you.

@swifto look at Add "Site search" in "Search engine" option. no examples no idea how to setup - #2 by Saoiray

Then kind of How do I use a custom search engine? - #8 by Saoiray

It’s instructing clearly. Go to the website you want to add and do a search. So when I did a search for Swifto, the URL changed to

The instructions are to replace your search term and everything after with %s

So would become

So on the third part, you put