How do I stop these notification requests

I have set this setting to no avail:

I still get these (please, for the love of God, make it stop):

You can disable location requests from the below settings page:

[Brave Settings > Privacy and security > Site and shields settings > Location]


It’s possible to disable all websites from seeing your location by setting it to “Don’t allow sites to see your location”. This will mean you won’t see any notifications, but instead see a blocked location icon in the browser address bar – as per the below screenshot.

Alternatively, if there are some websites that you want to be able to see your location, then you can use the “Customised behaviours” section on the same settings page to add sites to the allow list or block list.

I set the setting when you posted your replay:

I’m still getting these:

I do not know why this setting isn’t working on your machine. I tested it with the irv2 website as well and location notifications are blocked on that website too.

However, I don’t have a Mac to try it on – perhaps someone with a Mac can try it to see if this setting works correctly on their machine?


It is possible that you chose a setting (such as Until I close this site) prior to changing the default setting, which is why it still comes up. If you select Forever from the drop down, then hit Block for, does it still continue to ask if you leave and revisit the site?

Maybe. I went back to the web site and the popup didn’t show so I guess it’s fixed now :man_shrugging:

The settings have location and notifications disabled and my browser is still doing this!

As stated previously — I would recommend changing the drop-down to Forever, then clicking Block and it should stop these notifications for that site.

That is not a solution. I want these notifications gone for every web site I visit!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.