New Brave tracks my IP address even with a VPN

Description of the issue:
I just upgraded to the new Brave for mac because it says the old brave will stop being supported in 2 days and when I go to browserleaks.com, even with a VPN, it shows my actual location rather than my VPN selected location as one would expect.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
I’m in Fiji. In the new Brave, with or without Express VPN activated, I go to www.browserleaks.com and click on “IP address” and it shows my actual location correctly as Suva, Fiji.

In the old Brave, when I go to the same site with my VPN on, it shows the IP location as my VPN selected location, in this example, New South Wales, Australia. This is what I would prefer to have happen - my VPN selected location shown rather than my actual location, since Brave is advertised to be a secure/private browser.

Actual Result (gifs and screenshots are welcome!):
See above

Expected result:
I would expect the new brave to perform correctly the same way as the old Brave, not divulging the actual IP address of my machine while on a VPN server.

Reproduces how often:
Every time.

Operating System and Brave Version(See the About Brave page in the main menu):
New:
Mac OS Sierra 10.12.6
Brave Version 0.64.77 Chromium: 74.0.3729.169 (Official Build) (64-bit)

vs. Old:
Mac OS Sierra 10.12.6

Brave 0.27.3
V8 6.9.427.23
rev 2df8cb1
Muon 8.1.8
OS Release 16.7.0
Update Channel Release
OS Architecture x64
OS Platform macOS
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 69.0.3497.100

Additional Information:

Hi, have you looked at Express VPN yet?

"
Extended leak protection
Strong, proven leak protection is enabled by default, ensuring your privacy and security remains intact under all possible network conditions.
"
This feature is reserved for paying customers.

Many VPN providers restrict the free version, e.g. also the VPN provider “Windscribe”.
So the problem is most likely with your Free VPN version, but not with Brave.

I myself use the free version of “Hide.me”, this actually limits (as far as I know) only the amount you can download. Maybe you’d like to try it out? =)

Disconnected:

Connected:

Translated with www.DeepL.com/Translator

@johnkshea you may want to change it to “Device recognition blocked” via Brave icon at URL bar. Or you may want to change it globally via Settings.

IIRC, the settings in previous version is only “Block all fingerprinting”.

I am using the paid version of Express VPN as you can see in the screenshots I posted. Thanks for the reply though.

OK thank you I’ll try that and get back to you.

OK eljuno, I tried your suggetion, changing the settings from “3rd party device recognition blocked” to “device recognition blocked” and it still detects my exact location when I go to browserleaks.com even with the VPN on. Any other suggestions?

OK I did a few more tests. I did a DNS leak test, and IP test, and it is clearly an issue with the new version of Brave or the settings in the new version of Brave. I have both Brave browsers open. When I use the old brave browser that is losing its support today, I have no leaks. When I use the new Brave Browser, I get leaks. Weird.

Through a chat session with my VPN provider, I was instructed on some diagnostics. I deleted and re-downloaded the new version of brave, rebooted my machine, cleared my caches, and rebooted my wifi and everything appears to be working fine now. I’m not sure why the new version of Brave was leaking my IP before (even with VPN active), but now it is not. Safari and Chrome browsers were also leaking my IP and now they are not. The VPN tech support said that perhaps it was a network problem with the cache on my router/wifi.

OK I’m having the problem again after only 1 hour. IP leaks on the new Brave, Chrome, and Safari, even with Express VPN turned on. The only browser that doesn’t get IP leaks is the old version of Brave that is on its last day today.

OK I uninstalled my antivirus and reinstalled my ExpressVPN and now its working again. Not sure why the issue came up only when I installed the new version of Brave.

Then it doesn’t seem to be Brave’s fault, with which the subject apparently loses its validity.

But as I said in the beginning, I wasn’t getting any leaks on the old version of brave even while I was on all the other browsers tested (new brave, chrome, safari). Now everything appears to be working OK. It seemed to be a problem with the new brave and my antivirus software which was resolved by uninstalling the antivirus (webroot) and reinstalling the new brave. Now I get no IP leaks on any of my browsers.

This topic was automatically closed after 30 days. New replies are no longer allowed.