How do I prevent DNS_PROBE_POSSIBLE error from occurring?

I have recently connected my computer to a new WiFi network as we have installed a new provider and router in our house. Connection to the internet is fine but Brave sites show nothing but an error with ‘DNS_PROBE_POSSIBLE’.

After some reading on these forums and some tinkering with Brave settings, I have found I could fix the issue by unchecking the ‘Use secure DNS’ option, however I feel that browsing with this setting turned off is less safe.

Is there any alternative fix to this issue? I am not using a VPN and I have tried the methods where I open a new profile, and the one with disabling extensions, even through a private window, none of these methods have produced lasting results. Websites load fine with other browsers on my computer, though I am typing this on my phone where Brave works just fine.

I apologize if this is the wrong place to post something like this, this site is quite confusing to navigate on mobile.

Hi

Try this:

  1. Open brave://settings/help, click on Version and reinstall Brave

If issue still there

  1. Open brave://settings/shields and set Brave shield as in image; Clear Browsing Data, flush DNS, Restart Device.

If problem not solved

  1. Change default DNS by DNS service such as OpenDNS, cloudfire, or google… (I personally use secure DNS).

I’m afraid none of these methods worked, I’m worried that it might be unfixable. I’m also not really sure what’s causing this issue in the first place.

Hi

Disable firewall to check if this what might be causing the issue.