How do I disable auto-opening Google results in a new tab?

I just want to click on a Google result and have the current tab redirect to what I click. Currently it’s defaulting to always opening a new tab. My other browsers don’t do this. How can I disable? Thanks!

1 Like

The Only thing I can think of is that your ctrl button is stuck/pressed in if on windows.
I never saw this before
oh maybe it is some kind of virus. Try checking for viruses and go to brave://settings/search set google as default maybe delete it and readd google.com. and also try checking if the links you are pressing on are not ads this happend to me before you can check that by looking upper left corner of the link of the google result. This is all I can do.

Sorry if it is a little confusing ny engllish isn’t that great.

1 Like

It’s not happening on windows, just macos. I can repro this on the newest build for mac…

1 Like

That Is some bad news for me tough I never used macOS I hope maybe the steps I listed will help.

Today’s update seemed to have fixed it… :partying_face:

1 Like

oh… clicking a link on google results opens the link in a new tab… happens on all os’s (win + macos) and on chrome as well so I think this a change in chromium itself… although bing still opens link from goog results in the same tab…

@Mattches any insights regarding this?

that’s weird i use linux and google result open in the same tab

just a questions do you loggin to google while you use it

there also setting in the google search check this

and despite you loggin or not make sure this option is unselected

Open each selected result in a new browser window

hope that help and have a nice day

2 Likes

That was it, but I never set the option… just results where opening up in new tab… :thinking:

i do not know maybe it was default earlier then they change their mind but kept the old user who used it to behave like that

not sure

I’m confused – I cannot reproduce this on any OS. When I click on Google search results, the page loads the link I clicked on as intended. Are there certain steps that I’m missing here in order to produce the issue?

there option on the google setting that make that behavior

@Mattches

Yeah, that settings link on google’s page was the culprit, but also at play was some wonky config functionality with google… 1. the setting was turned on for me but I never knew about this setting and never set/unset this setting - also I’m always logged into my goog account. 2. I’m guessing because google using sharding that the config needed to be done across all browsers - ie. made the change in brave but going into chrome showed the old setting value was used. Edge worked as intended… This was at work today using windows… At home last night using mac, brave opened result link in new tab and chrome worked as intended… So not a brave issue(?) just some wierd google shenanigans…

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.