High CPU usage and processes not closing on Ubuntu (Pop OS)

Description of the issue:
Hey folks. As of about one hour ago, every time I open Brave (1.26.67 Chromium: 91.0.4472.114 (Official Build) (64-bit)), it starts to eat up my computer memory, even if it’s just sitting on the homepage. When I close the browser, the processes don’t close and continue to run with very high CPU usage. I have to manually kill the processes to stop them.

I’m using Pop OS 21.04, Kernel: x86_64 Linux 5.13.0-7614-generic.
I ran apt update just before this started and I think the linux kernel version updated, so that’s a possible culprit.

How can this issue be reproduced?
Install and open Brave on a fully updated version of Ubuntu 21.04 or Pop OS 21.04. 21.10 is likely also affected.

Here’s a gif showing the processes in the system monitor, their high CPU usage, and me having to manually kill them to get them to stop: https://i.imgur.com/mkD4aRf.gif
I only have one instance of Brave running in the above gif.

Edit: Forgot to mention, I’ve tested this on two different machines, with the same result on both, so it’s not a laptop/pc issue.

How did you install Brave?

Can you update it and re-test? That version is pretty old by now.

That worked perfectly. Added it to my package manager and it updated. Must have downloaded the deb file originally. Cheers!

1 Like