High cpu usage and no google automatic translation

hello my problem is that brave is using more cpu compared to google chrome. (Tried by opening 1 single site in 2 browsers) The other problem is that there is no automatic translation in brave in google chrome. I believe you will provide a solution to this with this sad and new update. Thank you.



Its that website, https://canlidoviz.com/ causing a CPU jump for me. Occurs in Chrome (and Firefox) also. Guessing all the real time updates is the issue

The cpu problem does not persist for now. But the automatic translation needs to be included with the update. I don’t need to learn the language to read the site. I browse sites other than English language and translation is like a jewel for me.

Brave doesn’t have it. And I don’t think it is likey it ever will.
Full translate is a chrome feature. Both belong to Google. So chrome has direct access to the Google translate API without restrictions.

Third party can’t just add this feature. It needs to be licensed. You can install the Google translate addon into brave and at least translate text with it. It is not as convenient though as it is in chrome.

I might switch to chrome just because of this, but whatever.

Just install the google translate extension? regarding CPU usage, thats the site issue, affects all browsers I tested at the time.

Hi

  1. Make sure your hardware acceleration is disabled at brave://settings/system
    Opening the page did nto affect my CPU resources.
  2. Unfortunately, Brave does not offer to translate websites.