Help! "Show in folder" not working properly on Linux Mint 19 (Ubuntu 18.04)

Description of the issue:

After I open the brave://downloads page, when I click on the “Show in folder” button for any file previously downloaded, instead of opening the file browser (caja) I get an error message in a small window that says: unable to open <file_name_complete_path> because it is not a folder. (of course it cannot open this folder… it is a complete FILE path…)

I am using Brave 1.9.72 on Linux Mint (Cinnamon edition) v. 19 (based on Ubuntu 18.04)

Please take a note of the following:

When I click on the three vertical dots and then select “Open the download folder” Brave successfully open the configured default download folder using the proper file manager (caja).

Could a developer tell me where to look to see if I can modify something in a script somewhere to fix this issue? I like Brave very much but this is a “show stopper”.

How can this issue be reproduced?

  1. Open the downloads page
  2. Click on “Show in folder” for a previously downloaded file

Expected result:

Brave Version( check About Brave):

[Version 1.9.72 Chromium: 81.0.4044.138 (Official Build) (64-bit)

Additional Information:

Please excuse my English. I am french-canadian and I am using the french version of 1.9.72. I tried to translate what I see as best as I could.

Thanks a lot in advance for your help.

Guy L.
Laval, QC

1 Like

Bonjour, Guy @guyl6308, et bienvenue. Your English is better than that of some native speakers I know. :slight_smile:

I am unable to reproduce this problem using Brave 1.9.72 Chromium: 81.0.4044.138 (Official Build) (64-bit) in Linux Mint 19.3 Cinnamon 64-bit in a Parallels virtual machine. Are you using a different version of Mint?

I did a bunch of updates to the OS and apps just before trying it, including a kernel update. I suggest running Update Manager to be sure that’s not the issue, and if it still occurs, perhaps reinstall Brave after backing up your Profile folder - reinstalling shouldn’t touch it, but better safe than sorry. Your Profile folder should be named Default or Profile [#] in ~/.config/BraveSoftware/Brave-Browser/ (click images to enlarge).

Thank you very much HNK for your reply.

Unfortunately, this computer is on Linux Mint 19 (not 19.3 like you) and it is a production system that I cannot update at this time. However I rebooted it and now the behaviour is a little bit different:

I still get the error message window saying the location that I am trying to open is not a folder (it lists the complete file path instead of the folder where the file is)

AND Brave opens my file manager (caja) on my home folder (not the dowload folder)

There is someting weird going on…

I am thinking that maybe I should take a look at the xdg-mime and/or xdg-settings scripts that Brave installed in the /opt/ folder. Those are “local” copies that Brave might use instead of the “standard ones” in /usr/bin ?

Sorry, Guy, that’s beyond the limits of my knowledge. Perhaps @Mattches or @eljuno can help with this?

Bonjour Guy, are you able to take a screenshot of the actual error message or would that be too revealing of your local configuration?

It’s a little hard to know what exactly is going on without looking at the paths involved.

Hello fmarier!!

Thanks a lot for taking the time. Here it is. I have 2 screenshots for you

1/ The Download screen
2/ The error message when I click on the show in folder button for the file

In French “Telechargements” = Downloads
In French “Afficher le dossier” = Show the Folder (show in folder)
In French “Impossible d’afficher” = Impossible to display
In French “L’emplacement n’est pas un dossier” = The location (path) is not a folder

You see, instead of trying to open the location where the file is located


it tries to open the full file path as a folder:


Thanks a lot for your help!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.