Brave saves downloads in /run/user/1000-folders instead in download directory

This problem has been reported before, unfortunately without any suggestions or fix. Please check [Can't change default download folder from /run/user on Linux]
I have exactly the same problem: Whenever I want to download something brave opens a folder in /run/user/1000 by default and I have to navigate to the targeted folder. In firefox there does not seem to be any problem.

**Steps to Reproduce (add as many as necessary):

  • pre-step: confirm that the default location for downloads is set properly. (It is!)
  • navigate to any site with something to download
  • right click the content, select download
  • a folder like "/run/user/1000/doc/647576658 (random number) opens

Actual Result (gifs and screenshots are welcome!):

  • see above

Expected result:

  • the folder that is stored as the default download folder should open

Reproduces how often:

  • always when I try to download anything, even an image

Operating System and Brave Version(See the About Brave page in the main menu):
System: Kernel: 5.4.0-137-lowlatency x86_64 bits: 64 compiler: gcc v: 9.4.0,
Desktop: Cinnamon 5.2.7 wm: muffin dm: LightDM Distro: Linux Mint 20.3 Una
base: Ubuntu 20.04 focal
Brave 1.40.107

Additional Information:

As reported at the very bottom of the thread you linked, I was able to resolve this problem by deleting the snap version of Brave and installing the native version from the repository. The native version does not have this problem.

Thanks for the quick response! This might get me somewhere!!
I had thought all along that I was using the standard version, because I just (re-)installed it on the command line. Now it looks like I also have a second snap-based installation on my machine, which starts when I launch it from the taskbar and which I was not aware of. I just started the browser via the command line and now I am seeing the standard version.
I will definitely walk down that path and kill the snap version. However, when I just tried to do that a minute ago I was not able to migrate all the settings, the passwords etc. over to the standard solution, but there should be a way to do that. I also have not yet figured out how to remove that snap-thing (which I never asked for in first place…), because I have not not found it yet.

The safest way to migrate your passwords and settings is to use Brave Sync. Launch the version with the settings you want to save, go to Settings → Sync → Managed Synced Devices. Scroll down to Sync Settings and select the items you want saved, or “everything.” Then go up top to the devices and add your other instance, or else choose “View Sync Code” and copy it. Now launch the other version, go to the same settings, and add it to the Sync chain or make sure it is on the sync chain. Again scroll down and select the items you want to sync.

Thank you, that really helps! In fact I should have read your initial response to the previous problem statement more carefully. It just never occured to me that I might have two versions of brave on my hard disk. Anyway, the problem is solved and I am very happy to get that annoying behaviour out of the way!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.