Clicking on Brave Icon Does Not Open Browser

bug

#1

Description of the issue:

When I click on the Brave icon in my menu Brave I get the “working” cursor for a few seconds and then nothing opens.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

This happens every time. It began after Brave froze and I had to reboot. It happens whether I choose Brave from the startup menu (Linux Mint) or the icon on the bottom tray.

Actual Result (gifs and screenshots are welcome!):

Nothing to screenshot. Brave just doesn’t open.

Expected result:

I would like Brave to come up.

Reproduces how often:

Brave Version(about:brave):

I can’t open Brave to see the version.

Reproducible on current live release (yes/no):

Additional Information:

I am on Linux Mint on a ZaReason laptop. I have been using Brave for only a few weeks so my version cannot be very old.

I am able to open other browsers (Chrome, Firefox) just not Brave.

I am very hesitant to reinstall Brave because I’ve already put Basic Attention Tokens into my Brave Wallet and I don’t want to lose them.

Thank you!


#2

Which version of Brave are you running ?


#3

As I mentioned, I am not able to open Brave to see the version number. Is there any way to see the version without being able to bring up the application?

Daryl


#4

@darylk,
From where did you download Brave?


#5

I too am experiencing this problem. I am brand new to ubuntu and am running ubuntu 18.04.1 LTS and for whatever reason when i click the brave icon it briefly loads and then nothing. I have uninstalled it and reinstalled but the same end product. Any help would be much apreciated.

When trying to install it in the terminal this is the error i receive

laptop@laptop-HP-2000-Notebook-PC:~$ sudo apt update
N: Ignoring file ‘brave-browser-release-’ in directory ‘/etc/apt/sources.list.d/’ as it has no filename extension
E: Malformed entry 1 in list file /etc/apt/sources.list.d/brave-browser-release-.list (Component)
E: The list of sources could not be read.


#6

@thatbritishguy,
Try the following:
In the terminal, enter rm /etc/apt/sources.list.d/brave* then rerun the installation commands from the echo step to the end.

Let me know if this resolves your issue.


#7

still no luck from this.
laptop@laptop-HP-2000-Notebook-PC:~$ rm /etc/apt/sources.list.d/brave
rm: cannot remove ‘/etc/apt/sources.list.d/brave’: No such file or directory


#8

Open your terminal and type cd .config/ - do you see any Brave folders in this directory?


#9

there are no brave files in the directory.


#10

So what happens if you try running the instal instructions found here:


#11

Please run the following in exact order

1. sudo apt remove brave-browser
2. sudo apt purge brave-browser
3. sudo apt-get clean
4. sudo apt-get update or sudo apt update
5. sudo apt-get install brave-browser brave-keyring or sudo apt install brave-browser brave-keyring

The first 2 commands only work if you have installed it using the instructions from here.


#12

Hi Sriram. If I execute these commands will I lose the cryptocurrency in my Brave wallet?

Daryl


#13

Ideally nothing should happen to you profile because we are just nuking the app install. Just to be extra safe you can either backup your wallet before performing this or you can backup the profile folder and then try the steps.

You can open Files, show hidden contents by pressing Ctrl+H, open .config\BraveSoftware and renamed the Brave-Browser folder to Brave-Browser_old this should backup your profile folder.


#14

Great! Okay, I will backup and try the reinstall.

Daryl


#15

@sriram

I tried the uninstall / reinstall steps that you gave. I had the same problem (click on the Brave icon - wheel spins and then nothing happens) so I decided to try a reboot as follows:

Uninstall Brave
Reboot
Install Brave

This gave me a slightly different result. The Brave browser does come up for a few seconds, and then vanishes. Then I get the same problem as before.

Other thoughts?

Daryl


#16

I also tried the installation instructions given by @Mattches above. Same problem.

I also tried running brave-browser from the command line. I got this error message:

[8671:8671:0127/143946.945947:ERROR:broker_posix.cc(43)] Invalid node channel message
Bus error (core dumped)

Is this helpful??

Daryl


#17

Hi, been happily using brave browser for long while …got the latest upgrade too…this morning it only loaded the homepage but wouldn’t allow me to load any bookmarks…tried a restart of PC but nothing works…yesterday i closed PC using the on/off button and the message says brave didn’t close down properly…click on restore and nothin still


#18

@darylk,
Can you try launching brave from the terminal and include the --disable-gpu flag? I’m wondering if this is a display issue you’re experiencing.

@richard1,

Would you mind providing some more detail surrounding your issue?


#19

I am also having the same experience on Windows 10 , since the past few days. Each time I try and open the application from the desktop or taskbar, there is no response for approx 20 seconds. Clicking on the icon again prolongs this time until eventually the app starts up.

This bug has only started to appear, and still exists on uninstallation & reinstallation of the app & full PC restart.

Using Brave Browser version 0.58.21 Chromium: 71.0.3578.98 (Official Build) (64-bit) & latest Windows 10 build ( fully updated with all drivers )


#20

@xdunal3306,
Can you try disabling Hardware Acceleration and see if that helps the issue? To do this, toggle off the option by navigating to Settings --> Advanced --> System --> Hardware Acceleration