Brave Browser is Crashing my PC

Description of the issue:

Brave Browser (randomly) freezes my Desktop PC and requires a hard reboot in some cases. I noticed that this issue happens more often when trying to connect to YouTube or while it is already open in a tab so it could be a GPU spike crash but I’m not entirely sure.

How can this issue be reproduced?

  1. It is seemingly random and therefore hard to reproduce at will but having YouTube open or trying to connect to it causes the PC to freeze for a while or completely (in some cases) requiring hard reboot. I suspect it to be related to hardware acceleration and GPU spikes but cannot confirm it.

Expected result:

I expect the browser to not hard crash my computer or freeze it temporarily.

Brave Version:

Version 1.27.109 Chromium: 92.0.4515.115 (Official Build) (64-bit)

Additional Information:

  1. This issue only happened to me on Windows 10. Linux (Arch / AUR brave-bin) seems to be either immune or less affected.

  2. My GPU belongs to the GTX 10 series - NVIDIA Proprietary Driver.

1 Like

Good report. Brave Support may also want to know, if you have tried testing the “User hardware acceleration when available” switch at



Clear DNS cache:

URL: brave://net-internals/#dns

Click on “Clear host cache”

Clear browser cache:

URL: brave://settings/clearBrowserData

Select Basic

Set Time range to “All time”

ENABLE all three:

  • Browsing history
  • Cookies and other site data
  • Cached images and files

Click on the “Clear data” button

Hello, I had cleaned the DNS cache, cookies and browser data before the issue started to appear (I clean the browser regularly), however I did have Hardware Acceleration ON at all times, so I’ll keep it disabled and see if the problem still happens but as I mentioned above it is hard to reproduce at will (It’s random)

I am having a similar issue. Within several minutes of starting the Brave browser, my entire system will be completely unresponsive, include the keyboard and mouse. I have to do a forced power-off by pressing the PC’s power button for 5 seconds.

I have to get some work done now. But, in the near future, I will try disabling hardware acceleration.

Uploaded system information

I have tried using various versions of Brave, but they all do the same thing.

I have tried deleting the whole profile, but the problem still happens.

Please let me know if this resolved the issue. If not, it would be useful to have the crash report IDs from when these crashes occurred. You can find the IDs in brave://crashes

I have the same issue (AUR brave-browser)

Whenever I try to run brave with the latest version, it instantly consumes all of my RAM and CPU capacities.

I don’t know if it can provide any help, but here are some errors which are printed out when I try to run brave

Kubuntu 20.04, Linux 5.4.0-80-generic

Brave IMMEDIATELY locks up all processes in session, computer is unresponsive to keyboard, mouse and SysRq reset. REPEATEDLY happens after latest update.

Please don’t suggest fixes that have context of url entry brave://etc, please reread second word. Had to switch default to Firefox to enter this report. I can’t drive a broken car to the store to get a new part.

I’m having the exactly same problem as domore. I opened my Task Manager to see what was going on. I open brave, and 99% of my cpu is being used. And 15 tasks open, then brave freezes and then crashes 10 seconds later. This just started happening 30 minutes ago.

My issue appears to be resolved . I disabled hardware acceleration and restarted the system. :smiley:

Which GPU do you have? (and which drivers?)

I believe that information was provided in the uploaded system information that I gave in my original post.

Sounds like a different issue to me, this one: Brave browser suddenly crashing at start


If you are willing to somehow still take a whack at making the “old beater” run . . .

Quit everything and restart your Linux machine.

In a terminal window on your Linux machine, the following command might show the Brave Browser processes (if I wrote the following correctly):

top -o %CPU -p $(pgrep -d ‘,’ brave)

If that fails, simply try:


Even though Brave Browser is not yet running, leave that terminal window open/running.

In another terminal window, you might also try . . . one of two slightly different Linux commands for starting Brave Browser from the command line.

I do not have a Linux machine available, and I’m not quite sure if “brave” or “brave-browser” is the correct process, here. But, the remaining command line character strings for each, are the same, after the process name:

brave -n --args --disable-gpu --enable-leak-detection --crash-on-failure --incognito

brave-browser -n --args --disable-gpu --enable-leak-detection --crash-on-failure --incognito

The idea, here, is to somehow get Brave Browser running, from the command line, and using flags that might reduce its thirst for CPU/RAM.

If this test works, then go to, and ENABLE both:



The first - adblock cosmetic filtering - can reduce CPU thirst.

The second - would allow you to get some Crash IDs and send them to Brave Support.

Both of those possibilities, are mentioned in Brave Support replies by “Mattches” - - - who may be interested in your findings.

Good luck.

Command Line Flags in Brave - reference:


AdBlock tip at another Brave Community page:

1 Like


Thanks for the direction. brave-browser is the command on my machine, however

top -o %CPU -p $(pgrep -d ‘,’ brave) fails b/c -p requires an argument

brave-browser -n --args --disable-gpu --enable-leak-detection --crash-on-failure --incognito

starts Brave and top show 76% CPU usage before lockup so I still can’t go to brave://anything at all

I will look at the Ad Block setting next

For alternative solution

Check the thread below.

@Mattches The solution NOTICE: Users seeing browser freeze or crash may have faulty Ad Block Updater component doesn’t not work properly.

In this Brave crash upon opening the solution by @nivakis works perfectly!

1 Like

This did not work on my Linux machine