Google Drive Notifications STILL Not Working


Enabling Desktop Notifications for Google Drive Fails

  1. Launch Brave
  2. Browse to https://drive.google.com
  3. Go to Settings → Notifications
  4. Select the checkbox next to "Get updates about Google Drive items in your browser
  5. Note error pop-up in the lower left-hand corner of the Brave window: “Couldn’t enable notifications”

NOTE: Even if you manually add https://drive.google.com/* to the allow list for notifications within Brave settings, the same error message applies.

Expected result:
Notifications should work!

Brave Version( check About Brave):
1.23.73 - Windows and macOS versions both exhibit the same behavior

Additional Information:
I searched the community and found there are at least two other threads regarding this same issue - one in 2018 and the other in 2019. Both were closed due to inactivity within 30 days from the last update.

This seems like it should be trivial to resolve, but is still unresolved over 2 years after first raising awareness. Either this just isn’t a high priority, or it’s something that’s more difficult to resolve than it appears to be. In either case, it would be nice to know what the root cause is and if there are any plans to resolve it.

Brave development team - would it be possible to get a response on this?

Hi there @jeffh , welcome to community :slight_smile:

You may have some notification permission issues - try the link below to troubleshoot the problem:

and if that doesn’t work see can you try going to https://www.bennish.net/web-notifications.html, and forcing the notification to pop up.

Give this a try and let me know if this works.

Best,
Salty :banana:

1 Like

Hi - thanks for the tip, however, I’m using macOS Catalina 10.15. I noted that I observed the same behavior on Windows 10, but my day-to-day work is on a Mac. So…back to square 1?

1 Like

Hi @jeffh,

Would you give this suggestion a try? → https://support.brave.com/hc/en-us/articles/360058972091-Push-Notification-Test

Give this a try…

Best,
Salty :banana:

Hello @SaltyBanana

Thanks for your follow-up. I’ve tried that as well. Just to verify, I did the following:

  1. Navigated to https://drive.google.com
  2. Clicked the lock icon → Site Settings
  3. Changed from Allow to Ask
  4. Reloaded the page
  5. Clicked the lock icon → Site Settings
  6. Ensured that Notifications for drive.google.com are set to Allow
  7. Navigated to https://drive.google.com
  8. Clicked the Settings (gear) icon → Notifications
  9. Tried to select the “Get updates about Google Drive items in your browser” checkbox
  10. Immediately received the “Couldn’t enable notifications” error and the checkbox reverted back to unchecked almost instantaneously.

Google Drive notifications for the same Google account work in Chrome, Firefox, and Safari on the same computer as well as on other Mac and Windows 10 computers, so it appears as though this issue is isolated to Brave.

With all due respect, while I appreciate you offering suggestions, is there a more methodical approach to collecting logs to determine the root cause?

Site Settings - drive.google.com:

Google Drive notifications and Brave error:

@jeffh I understand your frustration.

This matter unfortunately has come up before in previous versions.
Can you take a look at this and share a screenshot.

Hello - unfortunately neither of those options worked. I’ve already seen the community post that you shared the instructions from (as well as one other) and tried what was recommended. I decided to try again just to make absolutely certain.

I tried:

  1. Adding https://[*.]google.com:443 then went to Google Drive → Settings → Notifications and selected the option for browser notifications - received the same error message.
  2. Adding https://drive.google.com:443 then went to Google Drive → Settings → Notifications and selected the option for browser notifications - received the same error message.

Are these notifications working for others? It’s odd that notifications work for every other Google app that I use (Mail, Calendar, Chat, and Meet), as well as for other applications (Salesforce & Quip), but Google Drive is the one app that throws an error like this.

Please let me know what else to try.

Very strange!

Hi there @jeffh thanks for your patience.

Let’s give this one last try…

Open Dev tools and capture console output

  1. Open the developer tools window
  • Menu → More tools → Developer tools)
  • Cmd + Option + i (macOS)
  1. When the window appears, click on the “Console” tab
  2. With the console tab open, visit the website in question and observe the console input. If the issue occurs after attempting a specific action/function of the site, make sure that action is performed as well, otherwise it may not be logged in the console.

Attach a screenshot of what the console produces.

I replicated your issue on different browsers and chrome seems to be the only one that offers notifications for Google Drive at this time.
If you would like to request this as a feature, feel free to open a thread in Feature request. I will log this issue for the Dev team.

Best,
Salty :banana:

Apologies for the delayed response. I didn’t receive an email that the thread was updated. As requested, I’ve provided a screenshot to show the developer tools console display while reproducing an attempt to enable Google Drive notifications.

I have the sneaking suspicion that Google Chrome will continue to be the only way to accomplish this (in the foreseeable future), so I will not pursue a feature request at this time.

I appreciate your assistance in getting to this point!

Thank you @jeffh,

I tried to replicate your issue with other browsers and this might be specific to google and chrome. If this something you would like, feel free to post a feature request thread.
Apologies for the inconvenience :frowning:

Salty :banana: