Google Drive - Can't enable browser notifications

linux
macos

#1

August 24, 2018!

OS:
macOS High Sierra v.10.13.6

Browser Details:
Brave: 0.23.79
V8: 6.8.275.24
rev: 51b49051a779f0db94fbcfd0df5faca781299ea0
Muon: 8.0.7
OS Release: 17.7.0
Update Channel: Release
OS Architecture: x64
OS Platform: macOS
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 68.0.3440.84

Hi, Brave community! Having some trouble enabling browser notifications for Google Drive.

  1. Checked site permissions under ‘Security’ tab. https://drive.google.com is set to ‘Always Allow’. Note: browser notifications for https://mail.google.com and https://calendar.google.com DO work. See below:

Site%20Permissions

  1. Default Shields are up. Tried toggling all options on and off. No changes upon refreshing. I’ve left default Shields up.

  2. On Google Drive, navigated to ‘Notifications’ in ‘Settings’ menu. See below:

  1. Selecting ‘Get updates about Google Drive items in your browser’ checkbox returns error message ‘Couldn’t enable notifications.’. See below:

Error%20Notification

Thanks for your time!

EDIT:

2019-01-30T00:48:00ZPreformatted text

I’m now running the latest version of Brave:
Version 0.58.21 Chromium: 71.0.3578.98 (Official Build) (64-bit)

The issue seems unresolved as of this current build. Now, when selecting ‘Get updates about Google Drive items in your browser’, I don’t get an immediate return of ‘Couldn’t enable notifications.’. Instead, I am able to check the checkbox but it does not remain checked after selecting ‘Done’ to leave the ‘Settings’ menu.

Please see below screenshot for reference:


#2

I’m experiencing the same problem, Linux here, Ubuntu 18.10, latest version of Brave


#3

Hi rauldipeas,

Thank you for your reply. I’ve updated my initial post with some recent findings. I’ve also updated the tags to reflect that the issue persists even with the most recent build and that it is potentially affecting Linux/Ubuntu users as well.


#4

Looking into this right now, thanks for posting @roople_pooples.
Off the top of my head, try manually adding Gdrive notifications to the allow list in settings.

  1. Open the main menu, Settings --> Advanced --> Privacy and Security --> Content Settings --> Notifications
  2. Click the Add button next to the Allow section
  3. Enter the following address in this format: https://[*.]google.com:443
    • You might also try https://drive.google.com:443 if the above doesn’t work.

#5

Don’t work, still the same… :confused:


#6

Thanks for the quick reply, Mattches. I had actually already allowed Google Drive notifications in Settings, making sure TCP port 443 was open for SSL encryption. Appreciate the idea though!

Glad to hear that you’re actively looking into this, I’ll check back regularly for updates. Thank you again.


#7

We released an update to Brave today, can you (anyone encountering this) check and confirm if this issue is still present after updating to v0.59.34?


#8

Hi Mattches,

Unfortunately the latest update doesn’t seem to fix the issue.


#9

Thank you for confirming.
I’ll have to look into this some more. You may be encountering an issue related to this one logged: