Google Drive desktop notifications are broken in Brave for Windows

windows
#1

As per this earlier thread Google Drive - Can't enable browser notifications I cannot enable Google Drive notifications in Brave for Windows, either via the popup asking if I want to, or the Google Drive website’s notification settings (I toggle them on, but they’re off when I next visit that settings page).

Version 0.62.51 Chromium: 73.0.3683.103 (Official Build) (64-bit)

0 Likes

#2

Haven’t had this issue but would try to replicate it

0 Likes

#3

Hi @Wizardling,

Sorry for your troubles here. Are you running Windows 10?

We’ll get to the bottom of this!

0 Likes

#4

Yes to Windows 10. Other site’s desktop notifications like Google Calendar work okay with Brave.

0 Likes

#5

@Wizardling,
In the Notifications menu (Settings --> Advanced --> Privacy/Security --> Content Settings --> Notifications), does drive.google.com appear in the Allow list?

1 Like

#6

Yes, it is there as:

https://drive.google.com:443

I’ve yet to see a notification, though, and Google Drive certainly thinks it’s not set. I just tried deleting this setting, and re-enabled notifications for Google Drive in Brave. But it’s still broken in the exact same way.

0 Likes

#7

We have seen this happen before for some sites, most likely related to this issue:

I’m going to add your report to the thread so we can get as much data on this as possible. I know it’s rather unsatisfying that this thread hits the same dead and as before but I will try to make some noise about this as it’s been around for a while.

Appreciate your patience.

1 Like