Brave won't let me login to google account error 400

image

I have been trying to access a few google sites such as gmail, classroom, calendar, slides, docs and sheets.
I keep getting this Error 400 saying: " The server cannot process the request because it is malformed. It should not be retried. That’s all we know."
I’ve cleared my cookies, browsing history and cache numerous times already but nothing changes.
I’ve disabled the brave shields and nothing has changed.
Removed the extensions that may have been blocking something and have allowed all cookies but still, the error persists.
What else can I do? I’ve tried to debug this for an hour or two.

2 Likes

Hi

  1. Open brave://settings/cookies then add www.google.com to Sites that can always use cookies

  2. Hold Windows Button+R, Enter cmd , paste ipconfig/flushdns then push Enter

  3. Clear Browser cache then restart Device.

If not working try google public DNS 8.8.8.8, 8.8.4.4 or ISP DNS

1 Like

@CerealLover I just tried everything you mentioned including changing my dns to google’s one but it still gives me the same error. Sometimes it just doesn’t load the page at all saying: “accounts.google.com redirected you too many times.” or just the previous message. I really don’t know what to do at this point.

image

1 Like

@CerealLover Hey sorry for the late reply. I tried all of the above including changing my DNS but still nothing.

image

This is what appears now or occasionally the other message in the previous screenshot.
Sorry for the late reply, lost access to the old account so I made this new one.

Thank you for your help.

@xeno2,
Can you try logging into Google in a Private window and see whether or not you get the same results?

1 Like

@Mattches Just tried it in both the private window (CTRL+SHIFT+N) and the tor private window (ALT+SHIFT+N) and it appeared to have worked and I was able to login to my docs and gmail etc on both pages. I don’t know if its meant to happen but when I hit the sign in button in the top right corner when at www.google.com, it just refreshes the page and doesn’t actually sign me in but thankfully everything else I need works.
Thanks.

So it seems to be something in the profile itself that is causing the issue. When you cleared cache/data, did you do so for “all time”? If not, you might try that and see if this resolves the issue in your main profile.

1 Like

@Mattches Thank you so much it worked!! I just cleared all the data and cache making sure that it was all time and went into the advanced settings and cleared most of that too from all time.

Thank you very much, I owe you one. :slight_smile:

1 Like

You’re very welcome.
I’ll leave this thread open for now in case the issue shows back up.