Error when trying to access Gmail

I see there was a conversation 2 years ago about this topic, and I tried doing the corrective steps, but I am still getting the same response 400. That’s an error.

The server cannot process the request because it is malformed. It should not be retried. That’s all we know.
I have tried uninstalling/reinstalling. I have cleared all cache and other options.
I have been using Brave for over 2 years with no issues, and all of a sudden 3 days ago I started to have an issue. Any help would be greatly appreciated as I do not like Firefox, it is too slow for my needs. And none of the other browsers give me the safety that I have come to appreciate with Brave.

1 Like

Thanks for writing in @Sliverblur. Can you confirm your current Brave version and OS?

OS is Windows 11
Brave ver 1.42.97

Please let me know what I can do, as I love Brave over all the other Browsers BUT I need my gmail. :slight_smile:

@Sliverblur,
Can you test and see if you’re able to login to your gmail account:

  1. In a private browsing window?
  2. In a newly created profile?

I do not like having to create ANOTHER profile, as I run many email accounts for business purposes.
BUT I was able to get logged in with my account in a private window.
Is this the solution? having to use incognito mode?

@Sliverblur,
Apologies for the late reply. No, I was simply testing the Private window to see if there was in fact something in your original profile that may be causing this issue — which does seem to be the case given that you’re able to login without issue when using a Private window.

I would say that in your main profile, if you have any extensions installed, you can try disabling them to see if one of them is causing the conflict — however I’m going to wager that clearing your cache/browsing data for “all time” is what is going to resolve the issue as it typically does for this particular gmail problem.

I know you’ve said you had tried this but I’m assuming not for all time? Please correct me if I’m wrong. If not, then go to Settings --> History --> Clear browsing data, select All time for the time range and check the Cached images and files option and then Cookies and site data option and see if clearing this data does the trick. I’d recommend restarting the browser after clearing as well before testing.

No worries, I always clear from the beginning of time, for that exact reason. You just never know.
I redid your steps and this is the error I received:

400. That’s an error.

The server cannot process the request because it is malformed. It should not be retried. That’s all we know.

I redid the steps again and still received the same error.
I checked my extensions to see if there were any errors and found that some of the Google extensions had been marked.
I removed them. Closed and reopened the browser. Cleared my cache again, and rebooted my computer.
And I still received the above error message when trying to open my email in the regular browser.
Let me know what the next steps are.

Thanks

1 Like

@Sliverblur,
Thank you for the information — very strange that none of that resolved the issue. Reaching out to the team for more input on this. Appreciate your patience.

Can you test in Brave Beta?

@fanboynz I believe that it will work for them in Beta for the same reasons it worked in a new profile/private window. Trying to see if there is a way to solve this in their main profile so that they do not have to create a new profile or use Beta, etc.

@Sliverblur,
Can you confirm that this only happens when attempting to login to Gmail? For example, if you go to Youtube.com and try to login using that same gmail account, are you able to successfully do so?

Not sure if this will help; @Sliverblur But could try this.

Close the Brave browser

Rename the Preferences file:
C:\Users\<username>\AppData\Local\BraveSoftware\Brave-Browser\User Data\Default\Preferences (Change it too Preferences-bak)

Restart Brave, and retest.

Hows the results of the testing? @Sliverblur

Thanks, fanboynz. I was having the same problem and your fix worked like a charm.

Only an issue with Gmail.
I opened and logged into Youtube with no issue.

This option did not work.
But thanks for this.

I was able to get logged in using the Beta program.
What I am not understanding is why all of a sudden I was not able to open gmail.

Please let me know what your thoughts are.

As I will continue to use the Beta program.

I replied to each of the steps, but here is a summary.
Failed with trying to change the preference setting by adding bak after preferences.
I can access my Gmail through the Beta program, which is great but for how long.

If there is any other information that I can supply to help ‘fix’ whatever issue I am having, please let me know.
I looked through my extensions and removed all Google-related ones, as some showed needing to be fixed.

Thanks again for all your help.

1 Like

If I may inquire dear, what exactly seems to be the issue(s) that you are experiencing with the brave browser… Pls be as detailed as possible as this will aid us in knowing how we might better be able to assist with your endeavors