Gmail won't load emails


Description of the issue:
When I go to Gmail.com the page loads, but when I go into an email, none of the main body of the email loads. I have scoured this forum and tried all of the suggestions. I have reset my cookies and cache, I have looked at the debugger for the site, I have cleared the cache storage from there, I have turned off my sheild… I have reset all of my settings… None of it is helping. All that I can do to fix it is to open a private tab and access my gmail from there. Gmail works fine in other browsers, it is just Brave, sadly, that is presenting with this issue. This is FAR from the first post about this issue. This needs to be fixed…

How can this issue be reproduced?

I cannot fix it, therefore, I cannot reproduce it.

Expected result:
to read my email with all of its content

Brave Version( check About Brave):
V1.35.104

Additional Information:
I want to send information from the debugger so that you guys can fix this, but I am unsure how to do that, and I have already spent too much time trying to fix this. Please give this attention… I love Brave… I have it on all of my devices and OS’s… but i cannot use a browser where I can’t see my email…

I do not use gmail, so I cannot replicate your issue. Also, it seems the issue is limited only to your device, as I have not seen others reporting it.

Go to the hamburger menu, create a new profile, do not change any settings in the new profile, login into your gmail account and see if it works normally.

You can check youtube tutorials/guides on how to send the logs. https://www.youtube.com/watch?v=H0XScE08hy8

[Gmail Page Won't Load]
[Gmail as of Aug 13 will not open in Standard mode, it forces HTML mode only on Brave Browser, please help! - #92 by tchkvsky]

This issues seems to have cropped up here a few times and gotten some attention… It might have been some time ago, but that begs the question of why it is still an issue…

I watched the youtube video. all of it and it explained how to test javascript. I looked on google to find some step by step instructions… I am not able to download the data from the console. I also tried what you said and created a new profile. Of course this fixed the issue since it is almost the same as opening a private window in that it does not have any of the data from my original profile. It seems like a cache bug of some kind. I am sorry I am not of more help when it comes to obtaining debug info.

Thank you for your help and your prompt response!

1 Like

I was having the same issue this morning. I was able to get my emails to load only after clearing the cache, browsing history, and cookies/site data for the past 24 hours and then I closed/reloaded the browser for good measure.

Also, I’m not sure if it made a difference, but I had 2 profiles open (a new one to test and my default one) and closed the new profile window last, so when I reopened Brave it opened the new profile and had to manually reopen the default profile.

Okay, so we need to clarify something before we go any further. You labeled your post as if you’re talking about Windows. But this Brave Version, 1.35.104 does not exist on Windows. The most recent Windows update is 1.35.103, with 1.35.104 being for Mac. So which are you using?

Sorry about that. Yes V1.35.103 on Windows

Thank you for your suggestions! I tried them to no avail =(

Ok, so I can feel comfortable looking at it. I just accessed my Gmail from my Windows 10 Pro that’s running Version 1.35.103 Chromium: 98.0.4758.102 (Official Build) (64-bit)

Gmail opens up no issues and all emails I run seem to open with no issue either. Could you try clicking on the Hamburger icon on the top right, go to Create New Profile and test gmail with that. Or you can try a new Private Window instead, but both are basic troubleshooting steps to try to see if it’s something either with an extension or a setting within your browser that is causing it.

I think we can solve the problem without really solving it. Make the new test profile your default profile. Go to brave://settings/braveSync, create a sync chain and migrate all your data from the old profile to new profile (cookies, bookmarks, history, extensions etc). If you are going to do this, then first properly migrate and verify that the new profile is working just like the old profile. Then and then only delete the old profile.

I see you said this as I was typing the above. But can you clarify steps you’re taking so we don’t make assumptions on what you did or didn’t do?

Sure. I have deleted all of my cookies, cache multiple times. I made a new profile and opened private browsing. Gmail works when I do both of those things. I cannot get it to work under my profile though…

I am running Win 11 Pro

What this suggests is that either a Shield setting or Extension is the problem. Most likely, it tends to be an extension that is interfering. For the next step, can you go to brave://extensions/ and turn the toggle switch to all of your extensions off, then try it? If it works, then try turning each one on one at a time while visiting, to see if you can find the one that seems to be “breaking” things for you on gmail.

Or, if it still doesn’t work when turning off, might have to ask what your Shield settings are.

CORRECTION
Actually, just toyed with settings. If Scripts Blocked is turned on, it completely breaks it. Same with blocking cookies. So it shouldn’t be Shield settings, but should completely be one of your extensions, or perhaps a weird interaction between multiple extensions. But I guess I’ll wait to see what you respond to let us know.

Sorry for the delay in response. Once I turned off all of my extensions, I wanted to track down which one might have been the cause. It was uBlock add blocker that was at fault. I am not sure why it was even on, but as long as it is off, I can access my emails. Thank you for your patience and for helping me to figure out the issue.

2 Likes

Glad we got that figured out for you. Btw, I’d suggest you remove things like Ublock or similar extensions. The reason being is that they aren’t really needed since Brave has an awesome built-in adblock that they are always updating. Not only that, but the more extensions and modifications you make to your browser, the easier it will be for websites to fingerprint and track you. Not to mention, sometimes they don’t like each other and you can have websites break like you just encountered.

If you ever go to websites where you see ads appearing, it’s recommended you share it in #support-and-troubleshooting:ad-blocking and staff, (especially @fanboynz ) is really good at looking through and modifying code so those sites won’t show ads anymore. (especially if it’s on desktop…not as easy for mobile, particularly iPhone, lol)

1 Like

There was a regression from uBO and then fixed.

Related thread. It should be fixed in Brave, if not force update Brave Ad Block Updater in brave://components/

3 Likes

if you using Windscribe tried to whitelist GMail from windscribe because when I tried it it is worked.

Same issue on Mac running 10.15.7 (Catalina)– removing uBlock fixed Gmail fail to display.

1 Like

This worked perfect :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.