Gmail as of Aug 13 will not open in Standard mode, it forces HTML mode only on Brave Browser, please help!

I’ve been using brave for almost 2 years and never had this issue till today, when I tried logging into my Gmail account as usual, and it would not load normally, saying that it needs to load in the HTML version, as opposed to the standard version it should load in.
Here is the message that now shows up at the top left of my Gmail window while using the Brave browser:

“You have been redirected to the basic HTML version because this browser is not supported. To use standard view please upgrade to a [supported browser]”

I thought maybe there is an issue with Gmail so I opened it up in Chrome to check, but no issue there, it opens normally in standard mode no problem. The issue seems to be with Brave for some reason.

I tried taking the Shields down in Brave for Gmail, as well as clear cache and cookies completely, and still the issue persists. I have the latest version of Brave.

Can you please help with this? I want to be able to use my Brave browser as I normally had in the past with my Gmail, as I do not want to have to use Chrome!

**Brave Version
Version 1.28.105 Chromium: 92.0.4515.131 (Official Build) (64-bit)

1 Like

I’m surprised to see yet another thread regarding Gmail, although it works all right here on my end.

Could you please check whether Gmail works normally when opened in a private window? Just make sure you don’t have any third-party extensions allowed in private window.

I have opened Gmail in Chrome and it works as intended.
I’ve opened it in Edge also and it works.

It just seems to have a problem with Brave for some unknown reason, and it will not load normally anymore, only in Basic HTML mode.

Is that what you are referring to by opening in a private window? A different browser?

Open Brave → click on the hamburger menu at the top-right corner → New Private window → open Gmail.

Aaa okay thanks for clarifying :slight_smile:

I did that and Yes it works normally it seems in the Private window.

What does that mean?

Usually it means a third-party extension is the reason for the issues. Could you please disable all of your extensions and check whether Gmail works normally?

I do not have any extensions running when I select the Extensions option from the Brave menu…

Is there another place I need to check for extensions?

Worth to check

When you’re on Gmail can you check your Shields setting for Gmail? Click Brave icon on URL bar.

And make sure you don’t have script blocker enabled.

If you don’t have any extensions, check what @eljuno suggested. Although you mentioned bringing Brave Shields down doesn’t resolve the issue.

Thanks for the suggestion.

As I mentioned I have the shield completely Off on the Gmail webpage, so I don’t know where else I can check for that

1 Like

Check the following:

Open Gmail → click on the padlock icon in the address bar → Site settings → make sure you have allowed JavaScript.

Yup, just checked and java Script is enabled by default.

What I’m baffled by is that I didn’t do anything different since 2 days ago, when I did use my Gmail in Standard mode without issues, and now all of a sudden it only loads in HTML and tells me that the browser is not supported, as I had quoted in my initial message.

I’m confused lol :slight_smile: I thought maybe an update by Gmail or by Brave did it… It’s annoying to use basic HTML Gmail…feels like back in the day

Just to confirm, you have disabled Brave Shields via the Brave Shields icon in the address bar, correct?

Yup, the lion head on the task bar at the top.
Shields are down for this site it says

All right, perform the steps below:

  1. Open Gmail.
  2. Click on the padlock icon in the address bar → Site settingsClear data.
  3. Open brave://settings/clearBrowserData via the address bar.
  4. Select Advanced and set Time range to All time.
  5. Select Cached images and files and Site and Shields Settings.
  6. Clear data.

I had already done that before I posted my message, but I just redid it as per your instructions, and it is unfortunately still the same.

I do not understand why.

I even went to the Bottom of the Gmail inbox page, where you can click the link to Switch View to Standard and nope, it will not switch it from HTML, even when I click the link provided by Gmail.

I’m baffled…

1 Like

You don’t have any extensions at brave://extensions/, correct? I’m still unsure why Gmail works properly in a private window but not in regular.

Correct, no extensions. None installed at all.

Let’s try an unusual approach then. Open Gmail → click on the Brave Shields icon → enable Scripts blocked → refresh Gmail → now disable Scripts blocked → refresh Gmail once again.

Okay so I did the first step by enabling the shield and turning on Scripts.
Then relogged in to Gmail and I got this in a blank window:

" JavaScript must be enabled in order for you to use Gmail in standard view. However, it seems JavaScript is either disabled or not supported by your browser. To use standard view, enable JavaScript by changing your browser options, then [try again]."

I have not yet re-Disable Scripts and refreshed Gmail, but wanted to send that to you in case it helps with the puzzle in the meantime.