Gmail snooze "Pick date & time" not working in Brave

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting

Description of the issue:
When attempting to snooze an email (from within reading view) or multiple emails (even when single email is selected) from list view, the ability to select a specific snooze date and time is not working. The clock symbol can be clicked (or ‘b’ pressed) and the menu is presented. All options work except “Pick date & time” which should generate another window/frame to select the date & time (and does in Chrome), but in Brave nothing happens.

Exact URL of the website in question: or

Did the issue present with default Shields settings? (yes/no)

Does the site function as expected when Shields are turned off?

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
Yes, turning off Trackers & Ad blocking

Does the site work as expected when using Chrome?

Brave version (check About Brave):
Version 1.18.75 Chromium: 87.0.4280.101 (Official Build) (64-bit)

Can you tell me what Operating system you’re using? On my end, I’m able to click Pick a date & time and see the second calendar window launch, allowing me to set the snooze date. Note that this happens with Shields set to default settings so I’m not sure why you seem to have to allow Ads/trackers.

Would you mind opening a Private browsing window, login to Gmail and see if you get the same results?

Windows 10 - Auto-updating
Works in Private as expected.

Problem appears to be with VPN (Private Internet Access) which is not enabled in a Private Window. Added gmail to VPN exclude list, and behaves as expected. Not a brave issue.



No worries at all – very glad you got that sorted out. Don’t hesitate to reach out if you have any other questions or concerns! :slight_smile: