GMail doesn't work

bug
#1

GMail doesn’t work in Brave. In the same machine no problem with Firefox, Edge, Chrome and IE.

It shows the message (in Spanish)

Hemos detectado un problema con la configuración de cookies de tu navegador.

Habilitación de cookies

Asegúrate de tener habilitadas las cookies. Para ello, sigue las instrucciones correspondientes a tu navegador.

Vaciado de memoria caché y eliminación de cookies

Si tienes habilitadas las cookies y el problema persiste, vacía la memoria caché del navegador y elimina las cookies.

Ajuste de la configuración de privacidad

Si el problema no se soluciona vaciando la memoria caché y eliminando las cookies, prueba a ajustar la configuración de privacidad del navegador. Si tienes una configuración estricta, añade manualmente www.google.com a la lista de sitios permitidos. Más información

Brave Versión 0.60.45 Chromium: 72.0.3626.109 (Build oficial) (64 bits)

#2

Hmm. Unable to reproduce. I tried 0.60.45 Chromium: 72.0.3626.109 (Official Build) (64-bit) with shields on in Windows 10 Version 10.0.17134 Build 17134 and in MacOS X 10.4.3 and logged into GMail without a problem.

Do you have any extensions installed that might block, like uMatrix or AdBlock or Ghostery?

1 Like
#3

Hi hnktong,

The extensions I have in Brave are:

  • Dashlane
  • Tranquility Reader
  • Download helper

I’m using Windows 10

:slight_smile:

Tranquility Reader

#4

I installed Tranquility Reader and Dashlane and still was able to use GMail. There are a lot of results for download helper, so I didn’t try that.

1 Like
#5

@javier,
Can you try disabling Shields and then attempting to login?

1 Like
#6

Try just accessing https://www.google.com/ and then retrying Gmail?

1 Like
#7
  1. Navigate to gmail.com
  2. Once their, open your Shields panel (lion icon on the top right)
  3. Change the cookie control setting to Allow all cookies
  4. Let the page refresh, then try to login again
    If successful, you should be able to re-enable whatever your desired cookie setting was and be able login to Gmail without issue.

Let me know if this does not resolve your problem.

1 Like
#8

I am having similar problem with being unable to load gmail from MacBook Pro desktop macOS v10.14.3.

  1. Description of the Issue
    Gmail unable to load and get message detecting a cookie setting problem. See attached

  2. Steps to Reproduce

*1. Launch Brave
*2. Navigate to http://gmail.com
*3. Obtain attached screen

  1. Actual Result
    See screen attachment
  2. Expected result

expect to be prompted to login to gmail

  1. Reproduces Consistently?

Every time
6. Brave Version ?
Version 0.60.45 Chromium: 72.0.3626.109 (Official Build) (64-bit)

  1. Additional Information
    I’ve tried suggestion of navigating to gmail.com and opening Shields panel and changing the cookie control setting to allow all cookies, followed by refresh. But stay on same screen. Please help.
#9

Hi @GaryG,
Thanks for reaching out to us!
Do you see this message appear before or after you attempt to authenticate into your Gmail account?

1 Like
#10

Hi. I see the message immediately after I type in http://gmail.com and press enter. I never logged into google on the Brave browser. I assume the message is appearing before authentification because I am not prompted to enter my email or password as the message is displayed after I press enter.

#11

@GaryG,
Try the following (I know you mentioned that you’ve tried this method already but please bear with me):

  1. Click this link to visit the gmail website - https://gmail.com/
  2. Once there, open your Shields panel and disable Shields (top-right big toggle):
  3. image
  4. The site should refresh, after which, enter your login information
  5. If you successfully login to your Gmail account, you should be able to open and reenable Shields and, furthermore, authenticate into gmail with Shields up without issue in the future.

Didn’t work?
Instead of disabling Shields, change the Cookie control option to Allow all cookies and allow the page to refresh. Continue with steps 3 and 4.

Let me know if this resolves your issue.

2 Likes
#12

No luck, :frowning:

When I disable Shields. Nothing happened. No refresh. Just stayed on screen. So I did a manual refresh (cntl-r), and stays on screen.

Enable Shields. Cookies setting already Allows all cookies, refreshed again. Stays on screen.

Disabled Shields. stays on screen as before.

I even tried to reboot my machine and tried again. No luck.

#13

@GaryG,

  1. This is very strange indeed. It may also be a caching issue with your browser. Next thing to try:
  2. Open Brave, navigate to [Menu] --> More Tools --> Clear browsing data
  3. In the Clear data box, check each box and select For all time for your the Time range option, then click Clear data.
    • If you’re reluctant to clear your browsing data (perhaps you have saved tabs or sites in your history that you haven’t yet bookmarked, etc), stop a this step and let me know and we will adjust the process to clear only data that may be relevant to gmail)
  4. Close/reopen brave and attempt to login to Gmail again using the same steps as laid out in my previous reply.

Let me know what you find out.

2 Likes
#14

I went ahead w 1,2,3, closed/reopened brave, opened new window, and was able to sign in, and get to my gmail.

Problem solved. Thank you for your patience in helping me thru this issue.

1 Like
#15

Visiting google.com and then gmail.com it works :star_struck:

Thanks everybody for your help.

:slight_smile:

3 Likes
#16

@GaryG,
My pleasure!
Please don’t hesitate to reach out or create a new topic if you have any additional questions or concerns.

1 Like
closed #17