Suddenly my Gmail does not work

My Gmail suddenly complains that it needs Java to work.

This is a new thing, - it’s been working fine for a long time.

My Java is installed and up-to-date.

Hi, @JohnK625, is it possible you have an extension that may be causing the issue?

No, it was the Shields.

I finally noticed a mark on the Brave logo in the address bar, clicked on it, and it asked if I wanted to turn the Shields off for this site.

I clicked “Yes”, and now Gmail is working normally.

John

1 Like

I just now figured out that it was the Javascript setting in Brave.

I finally drilled down far enough to find it ( the Brave “Search” feature did NOT find it! ), and saw that it was disabled, and had to be enabled for specific sites.

So, I put in Gmail, and now Gmail works with Shield enabled.

Someone must have modified the Javascript operation recently.

That needs to be looked into - Java is used in MANY applications, and to universally disable it is a big mistake.

John K.

And more -

Even with the website added to the Javascript list in Brave, AND the Shields turned off, my https://www.chase.com site does not work.

This is a SERIOUS problem!

How can I go back to a previous version of Brave?

Or do i have to go back to Firefox?

I was able to go to Chase and have it load normally. I also use Gmail without incident.

What Brave browser build are you using?
Release/ Nightly/ Beta?

Are you sure everything is up-to-date? Did you shut off extensions for process of elimination?

Version 1.23.73 Chromium: 90.0.4430.85 (Official Build) (32-bit)

This just started happening yesterday.

I have not made any changes to the settings for quite a while.

My only extension is Google Translate.

Also -

Chase’s intro screen loads normally for me, but after I go through the sign-on procedure, it says that it needs Javascript, even though chase.com is listed in Brave’s Java list, AND the shield system is turned off for Chase.

Hi, @JohnK625, could you try going here brave://flags/ and check settings, try to see if it can help?

I’m not sure what else it might be, so maybe @eljuno could offer some suggestions, too, if this doesn’t help.

Also, if it doesn’t help, can you post what version Windows you are using? Thank you.

Mine does not have the third Java reference “Future V8 VM Features”, but the other two are the same.

John

Also - Windows 7, 32 bit.

J.

How about trying this suggested fix, see if it helps you…?

First try:

…and if that doesn’t work, try this…

Do you have Use hardware acceleration when available turned on or off, @JohnK625 ?
If on, could you try turning it off and see if it does anything, too?

@JohnK625,
Try clearing your cache/browsing data. By default, scripts are enabled in Brave. You must manually disable them. Further, check and make sure that Scripts in Settings --> Shields are still set to Enabled. I’m able to visit both sites mentioned (gmail/chase) without any issue using Brave’s default shields settings.

1 Like

I think I figured it out - sort of.

I have Brave on 4 computers here, and only one doesn’t work right.

It turns out that the problem computer is a 64-bit machine, but I’m running Win-7 32 bit on it.

The other computers are all 32-bit machines, and Brave works fine…

It has had a few anomalies with Win-7 in the past, but nothing as severe as this.

Could this be the issue?

John

@JohnK625,
It could be, but it’s very hard to say tbh. It’s been a while since you originally opened this thread – have you updated to the latest version of the browser? Does the issue persist after doing so?

Yes, and Yes.

I’ve had to go back to Firefox.