Gmail and other google sites not working on Brave

Hello everyone,

I have a problem using google sites on Brave

Description of the issue:

Gmail and other google sites do not work on Brave after last update (version 1.44.101, Chromium 106.0.5249.65). Also other sites (like Uphold for example) do not load.

Sites will not load at all.

I already tried accessing them with shields down, doing the whole log-in process with shields down, deleting all browsing data from all time, disabling and removing extensions, as well as solutions I saw on this topic in other forums. Nothing seems to work.

However, the google sites load when using private browsing.

I’m using Manjaro linux.

Steps to Reproduce:

Just access youtube, or gmail, or another google sites.

Actual Result :

Sites will not load, it seems like the browser goes on an “infinite loop”

Reproduces how often:

Every time I try to access a google site


1 Like

Since it loads in a private window, it makes me think that it could be an extension causing this. Try turning each extension off one by one to narrow down to the extension causing that

1 Like

Hi, thank you very much for your answer.

I completely removed all extensions, but still it does not work.

Is there anything else I can try?

Thanks again

Any error codes or anything ?

Nothing at all, it just leaves me in the new tab window without ever accessing the site.

I also tried without hardware acceleration, and adding all google sites to the sites that can always use cookies

see if anything from the above helps

Sadly no :frowning:

And I found other sites that do the same (like uphold, for example)

@Mattches @SaltyBanana please help. Thanks!

1 Like

Thank you for the detailed report.
To be clear, if you open a new tab, type in (for example) and hit enter, you never even land on the page — you simply stay on the NTP while the site “infinitely loads”?

I’m also curious if you’re logged into your Google accounts (I assume you are) when you see this error? If so I’m curious if this behavior changes if you remove your Google login information from Settings --> Autofill --> Passwords and then try to visit the site.

Lastly, can you please update the browser to the latest build, v1.44.105 at the time of writing this and see if this has any effect on the behavior?

1 Like

Thank you for your answer.

To be clear, if you open a new tab, type in (for example) and hit enter, you never even land on the page — you simply stay on the NTP while the site “infinitely loads”?

Yes, it is exactly what happens. It also happens with other websites, like Uphold for example.

I’am logged into my Google accounts, however there’s no login information saved on Passwords in my browser.

Regarding the latest build, I do not seem to find it for my distribution (Manjaro).

For Manjaro can did you look using the following commands?

I just managed to get v1.44.105, but the problem persists.

Any hint about what else may be causing this?

We’re seeing an increase in these types of reports lately, but they all seem to be caused by different things. I’m curious to know if you were to create a new browser profile whether or not the same behavior occurs when you try to visit the above mentioned sites?

I am having exactly the same problem. Suddenly yesterday morning, my gmail (multiple accounts) will no longer work in Brave and I’m desperate to fix it. Other Google search, Drive, Suite, Google Ads work fine but YouTube and gmail do not. I just signed into multiple Drive accounts now to check and can get in fine, but when I try to access gmail, no luck. I am bewildered because I’ve been using gmail on Brave for approx 5 years and have never had an issue (though I notice that other people on the forum have had issues).

Here are the details:

Mac OS X Monterey 12.6 from 2021 (software is up to date)
Brave Version 1.4…105 Chromium: 106.0.5249.91 (says up to date)

No new changes whatsoever to the computer. I just woke up everything the same as the night before and it just wouldn’t work, no changes to any settings or software. No evidence of any contamination (viruses, malware, etc).

Have tried:
restarting computer
closing and reopening everything
clearing cache/cookies (Brave seems to be having trouble doing this, I just get a prolonged spinning circle that never goes away)
turning off hardware acceleration (suggested in prior threads) & relaunching–no change either way off or on
turned on google login for extensions

I note that Mattches advised to upgrade to v1.44.105 which I have. I have also removed login information from settings > autofill > passwords. No change.

No error message or white boxes as have been noted in the past. Just nothing. Won’t load.

Gmail is working fine on Safari & Firefox BUT THE ADS! I can’t take the ads. Hoping to resolve this ASAP.

Thank you!

Thank you for the answer and your help.

In a new profile everything works normally. I wonder what’s wrong in the one I’m using.

UPDATE: Appart from creating a new profile, the last Brave update (1.44.108) solved the issue.

Does it also work for you when creating a new profile?

Thank you for the update. I’m not entirely sure why it wasn’t working in your original profile but I do know we’ve seen an uptick in cases like this recently that I’m going to have the team look at.

I’m going to leave this thread open for now in case we have any additional questions surrounding the issue.


Hello Mattches,

Just to let you know that after the last Brave update (1.44.108), this issue seems solved.


Thank you for the update — just to confirm, this issue was resolved in your original profile after the update?

It was not resolved for me after the mosr recent update. However, it did resolve when I created a new profile. It’s a bit of a pain, but I’m so grateful it worked! Thank you so much for the help!

1 Like