Getting Ads on Brave

Description of the issue:

I did a factory reset for my laptop and installed brave after that. I am having issues after that. (Earlier it used to work)

I am getting ads on pages. YouTube videos show ads at the start of the video and websites have re-directs that are not blocked by brave. I explored the community page and found some articles relating to it but that didn’t work out for me.

One thing that I have found is the components were not updated. I visited brave://components/ and did an update check on all the components.

The following of them shows Version and update error:
NTP Super Referral mapping table - Version:
Brave Ad Block List Catalog - Version:
Brave Ad Block Updater - Version:
Brave Local Data Updater - Version:
NTP Background Images - Version:
Brave Wallet data files - Version:
Brave Ad Block Resources Library - Version:
Brave HTTPS Everywhere Updater - Version:

I think that this is the root cause of the problem. I have re-installed brave multiple times. Is there any other way we can fix it?

My ads tracker always shows 0 ads blocked when I have enabled all the shields.

Windows 11 22H2 (OS build 22621.1555)
Brave browser version: 1.50.121 Chromium: 112.0.5615.138 (Official Build) (64-bit)

1 Like

Does changing ad blocking to aggressive help ?

1 Like

It does not. I have tried copying settings of custom filters as well with no difference. It seems as if the ad blocker is not working at all, no matter the settings. I have also checked that no third party extension or application is affecting this. Also, tried to turn off my antivirus and windows defender with no luck.

Could you install brave nightly / beta if issue persists ?

Agreed. It means it’s not installing anything it needs. Where are you downloading from? It seems like it’s either not a legit version of Brave or you have something that’s preventing Brave from doing its updates.

1 Like

I had similar issues with Brave Beta. I would see ads if Brave Ad Blocking was enabled and at aggressive. If I turned on UBlock Origin the ads stopped. I had to nuke Brave Beta from orbit including the Brave Data folder and reinstall it from scratch.

1 Like

I am doing it from the official brave website Download Brave | Brave Browser.

I have no idea what is blocking it from downloading everything. It worked before I did a system reset. I had to do a reset because I messed up some registry entries.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.