Full Screen Issues on Mac

Long time Firefox user. Just moved all my browsing to Brave. One thing is a real pain and not sure if I can change it.

I have three screens (my main iMac screen and one extra each side).

In Firefox, if I click to full screen a YouTube video, it full screens it ON THAT SCREEN, with my other screens still available. However in Brave it goes into that HORRIBLE Mac OS full screen thing where the video goes full screen but switches to a new desktop, meaning the other two screens are blank.

I do a lot of tutorial watching while I edit stuff in other programs, I can’t do that any more :frowning:
Any idea if this is something I can change so that clicking full screen only applies to that one screen?

1 Like

Hello there @NoMoreFirefox please accept my apologies for this issue.

Please provide the following information in order to investigate further:

  1. Description of the issue:
  2. Steps to Reproduce (add as many as necessary):1.2.3.
  3. Actual Result (gifs and screenshots are welcome!):
  4. Expected result:
  5. Reproduces how often:
  6. Operating System and Brave Version(See the About Brave page in the main menu):
  7. Additional Information:

In the meantime, please try to disable Hardware Acceleration through the macOS terminal. Follow the instructions below:

Open the Terminal and enter this command: open -a "Brave browser.app" --args --disable-gpu

Do let me know if you require further assistance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.