Another problem with Brave

Just got my first Mac. Monterey 12.1 with apple chip. Once again the Brave browser will not function properly. I installed it with no issues. I dragged it to the application. It opened with no problem and I can use it unless I go full screen. The minute I go full screen the block to enter the search disappears and is not able to be recovered unless I leave full screen. I have to say that I like this browser but Ive never had to spend so much time troubleshooting issues with it compared to anything else I’ve ever used. As for how I’m done with it unless there is an easy solution. All the privacy in the world is somewhat meaningless when I have to spend all day trying to get the browser to browse.

the expectation is that I can use the brave browser in full screen mode. I also dowloaded the most current version.


Description of the issue:
How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Additional Information:

When you say “go full screen” you mean browsing while full screen, not while a video is playing, is that correct?

On my end, also using macOS 12.1 Monterey w/M1 chip, I’m able to enter full screen browsing without any issue. If I understand you correctly, doing this works, but the toolbar/address bar at the top of the window disappears — is that correct?

1 Like

yes that is exactly what I’m saying. If I open the browser in full screen I can no longer use the browser since I am unable to type anything in the search box because it essentially has disappeared. I uninstalled, reinstalled 4 times and it’s the same each time. I even tried both versions of the chip even though I have the apple chip and it’s the same thing every time.

Do you have the Zoom setting increased at all or is it set to it’s default?
image

Additionally, to confirm, the browser is still functional while in full screen mode right? Its just that you can’t view the address bar? For example, in full screen mode, if you hit Cmd + L (this jumps the focus to the address bar) and type in brave.com (even if you can’t see yourself typing it) and hit Enter, it does navigate to the site, right?

Zoom is 100%. Cmd + L changes nothing nor does it bring the focus to the address bar

1 Like

Ah, I finally found this post again @wickee . I knew someone else had asked and Brave staff had responded, but I forget who and where. XD. I’m going to copy what I said and then see if you can share here if it solves the issue.

So I just searched for a while and it took me rephrasing it all sorts of ways to get what I do believe is the answer.

  1. Open Brave on your Mac
  2. Move cursor to top of screen where OS Toolbar is located and click VIEW
  3. In the drop-down menu that appears, click “Always show toolbar in full screen”

https://osxdaily.com/2014/09/25/show-missing-address-bar-safari/
https://support.google.com/chrome/thread/5420850/unable-to-search-when-in-fullscreen-mode?hl=en

I encountered the solution in articles from 2014 and 2019. I’m not sure how many browsers have that issue or if perhaps Safari and Chrome fixed it and Brave is just using the old coding from back then in the current browser.

Do let me know if you try it and it does what you’re looking for.

I wanted to let you know that this actually did resolve the issue. Unfortunately I’m going to stick with firefox because this was the third in a sequence of issues I’ve had with Brave where I was stuck until someone could problem solve something that shouldn’t have ever been an issue. Thanks for the feedback and maybe down the road I’ll give Brave a try again but I need something that is going to work without my having to constantly trying to get help to use basic functions.

You are pretty sharp because nobody at apple support could figure it out either and I would never have thought of this.

@wickee what’s sad is that this is been an issue with Apple since 2014. What I shared with you was actually something that was written originally for safari. So I wouldn’t say that that had anything to do with Brave and wouldn’t hold it against them, but I guess you’ll do what you need to do. And I don’t know what your other issues were.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.