Flash Settings Not Being Remembered

flash

#1

Brave is not remembering my Flash site or browser settings.
I am trying to play games on Facebook that require flash, and I setup Brave to always allow Flash however it keeps reverting itself back to Ask.
I am using Version 0.56.15 Chromium: 70.0.3538.110 (Official Build) (64-bit)

Is there a way to get Brave to remember my site settings for https://apps.facebook.com


#2

@METALHEAD,
I too am a metalhead :slight_smile:

Can share a screenshot of your flash permissions for me?
Settings --> Advanced --> Privacy and Security --> Content Settings --> Flash


#3

The settings look good, however when I first open Brave, flash is blocked.


#4

Here is what happens when you first load Brave, it shows flash as blocked when it should be allowed.


#5

Can I have an example game you’re playing on FB that requires flash? I’ve been trying to test this on my end but none of the games seem to require Flash to run?


#6

Yes my metalhead comrade. :slight_smile:
I play “My Vegas Slots” under this URL: https://apps.facebook.com/playmyvegas/


#7

Thanks for the link!
However, I was unable to reproduce this.
Tested using Release build (v0.56.15), under default Shields settings, I was able to play/access the game like so:


#8

I too can access it with the same steps, but my complaint is that once you set “allow” the browser reverts to “ask” after you close and re-open Brave.
I want the browser to remember my site settings so that I can open this URL without having to do these steps every day.


#9

Any update on Brave remembering my allow flash settings?
The latest update still contains the bug.


#10

@METALHEAD,
Sorry for the late response, it’s been pretty busy around here.
So I tested this the other day and was able to reproduce the behavior you’re describing. However, now that I’m trying again, I’m unable to reproduce. I’ve reached out to a couple team members for testing just a moment ago and I’m waiting to hear back on that.

Appreciate your patience :metal:


#11

@METALHEAD ,
Thank you for bringing this to our attention. I have found the steps to reproduce the issue reliably and I have logged it: