FIX/Workaround: Linux Session Restore, probably no proper closing during shutdown or reboot

Hi, this is more or less a solution to an open topic that has been reported as a bug, feature request, and where no one seemed to know what to do or what the cause was.

The Tl;Dr is basically:

If you run brave on linux, and you want to use the session restore / “continue where you left off” - feature and the restore confirmation box nags you, be sure to deactivate both settings:
let brave run in the background and confirm before closing multiple tabs

Suggestion (for the dev team):
Make brave display a warning that the two aforementioned settings will be deactivated when using the session restore - feature, that the other two options will be disabled by that setting under linux or by default - at least on linux; bc/ that looks like an issue otherwise and will regularly pop up.

Full version below:

Description of the issue:
First Browser start after boot / reboot always shows the Restore Session option, complaining that brave did not shut down correctly - you need to press the “restore session” by hand to do what you wanted it to.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Run Brave on linux and keep it open.
  2. Have Session restore (continue where you left off) and at least one of the options (let brave run in the background | confirm before closing multiple tabs) all activated.
  3. shutdown or reboot your PC without closing brave

Actual Result:
Next time brave starts, it will never open your saved session, it will always complain first that it did not shut down properly

Expected result:
Just restore my session, bruh, I just rebooted, or shut my pc down, I did not know my OS would just suffocate brave, I promise! (I also think on windows I never had this issue)

Reproduces how often:
Basically each time when you follow the steps

Operating System and Brave Version(See the About Brave page in the main menu):
Any Linux I used. Mostly endeavourOS. Any brave version. Flatpak or native.

Additional Information:
So, I am lazy, and never close my browser whenever I reboot or shutdown my PC. I just expect it to save my session, because it always did, and to restore it whenever I reopen my browser. However, brave never did that for me; at least not on linux.

I imagine that during reboots / shutdowns, the Browser session just does not get closed properly.
Ie. configure firefox to never ask to close all tabs, but brave in a way that it always asks for confirmation if closing multiple tabs.
You never confirm that dialogue, bc/ your reboot / shutdown just force closes the browser. That way, a config change could be the culprit (just never ask to confirm closing all tabs).
This is just a simple example as to how browsers could have differences in closing behavior - which would not relate to a bug → but a config change.

Just for the heck of it, I just tested the behavior of 2 settings based on my hunch.
1: Keep running brave in Background, AND
2. Warn me before closing multiple tabs.

  • but I did so only once, so reproductivity was time-limited.

Results: Deactivating one of these did not result in changed behavior.
Deactivating BOTH however, brave restarted after a reboot / cold boot immediately for the first time in ages without confirmation box.

Looks like those settings, while viable on windows, don’t play well on linux which kills applications way more aggressively as I imagine, and devs need to be aware that this issue will pop up if the settings are used in a manner like this.
; )

People will see this as a bug, bc/ under windows there was no such issue.
or feature request. or support request
ie Tabs Not Automatically Restored On Reboot

Yes, It is an issue. but it’s related to how the user session in linux terminates your running applications.
If someone wants to be warned to have open tabs, well, your reboot just messed this up.
Running in the background, well, that’s not an option anymore, nope.
You can either get nagged after forcing a shutdown on brave or have that functionality.

If Brave devs want you to have a smoother user experience on linux, with all of these options enabled, then it could be considered an issue, but as it stands, you can’t have nice tab closing warnings and seamless session restore at the same time (at least from my testings)
I hope someone finds this and helps anyone, because I’ve had this for months if not years now nagging me - not any more. (I don’t need brave in the background or tab-warnings, I know I have 100+ tabs open at any given time.)
Kind regards.
[edits: cleanup/grammar]

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.