Brave does not close properly

Description of the issue:
How can this issue be reproduced?

  1. I always close Brave using the close button on the top right.
  2. Lately, even though I closed Brave correctly, when I launch Brave, it claims it did NOT close properly and asks if I want to restore.

**Brave Version 1.2.42

Additional Information:
Windows 10 Home 1909

Thanks for reaching out to us.
Can you tell me if you have any extensions installed at this time?

Amazon Assistant for Chrome
Securify for Chrome

Can you try disabling these extensions and closing the browser the way you normally do and see if you get the same result (that the browser claims it isn’t closed correctly)?

I’ve been having the same issue for the last two or three days (after the latest browser update).

I get the same message every now and then on Linux Mint 19.3 (also, when I was on 19.2 and 19.1).

There’s something I just figured out that seems to be working for me. After closing my browser AND also closing the Brave icon that now appears in my tray (not sure why a tray icon is now a thing), I don’t get the “restore” prompt in my browser when I open it.

Hey @Citizen-Se7en
Would you mind posting a screencap of the tray icon? and what happens if you click/right click the icon?

The screen cap is at the bottom. I couldn’t screen cap the right/click context menu, but it is as follows (btw, I forgot to mention that I’m running the Plasma (KDE) desktop environment, in case that matters):
About Brave
Task Manager
Profile 1
Let Brave run in the background

A linux disto? Might try and VM it later out of curiosity. Just wasn’t farmiliar with it in windows.

What I’ve noticed works on another Linux variant, what was once debian, you can close using terminal also works with sudo kill app-name or sudo killall app-name depending on the distro.

No clue if that’s any help, considering the difference in distro but if it has terminal you should be good to go! :+1:

Hope that helped


PS- Don’t forget to ps -A to list the processess if needed.

The Amazon Assistant was already disabled. I disabled Chrome Security and still got the message.


I’ll try removing them.

I removed the two extensions and I"m still having the same problem.

Thank you for checking. Can you try closing the browser by right-clicking on the icon and selecting Close window and see if you get the same results?

Still have the problem.

Can you try creating a new browsing profile (Main menu --> Create new profile), browse for a moment then close it and see if you get the same results?

I’m trying to discern whether or not the issue lies in the browsing data, or the browser itself.

Creating a new profile appears to have solved the problem.

So to me this points to an issue with the browsing profile (or data within said profile) that you normally use. I believe if you clear your browsing data for All time (Menu --> History --> Clear browsing data) on your original profile the error should go away.

Clearing the browsing history on the original profile worked. Haven’t had the problem since.

1 Like