First webpage to load takes much too long

Description of the issue:

On my HP detachable, Brave will start quickly. As soon as I want to access the first webpage (any webpage), I have to wait around 20 seconds until it has loaded.

How can this issue be reproduced?

  1. Start Brave.
  2. Load any page.
  3. Close the app, restart Brave, same behaviour.

Expected result:

Brave should, of course, load the page as fast as my desktop PC does or as fast as it does with the second page.

Brave Version( check About Brave):

v1.44.108

Additional Information:

This has been going on since the last few versions; the updates didn’t fix anything.

1 Like

Hello there @dasdas1 does this also happen when you load a site in Private window?

If that’s the case, you can try disabling your extensions to see if the first page loads properly.

To Remove an Extension:

  1. On your computer, open Brave.
  2. At the top right, click Menu icon_MM.pngMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Or:

  1. On your computer, open Brave.
  2. On your extensions toolbar, right-click the extension you would like to remove
  3. Select Remove from Brave... from the context menu

Let me know if that works.

No extensions are installed. I’ll try the private window, but I have discovered st. else… In my home wifi, the issue doesn’t come up. At work, it does - but not with Edge or Firefox.

1 Like

Hello there @dasdas1 , thanks for the information. Which is your shields configuration? Do you have filters enabled on them?

Maybe try load your webpage with shields off on both Wifi connections, to see if they load properly.

Regards.

I posted about this also. Except with me it’s happening on every new page. Even brave://settings. Even file:/// url’s. Just now it happened o “new private tab” and I get “page unresponsive.” This has something to do with Chromium, I’m getting it on every Chromium engine browser. It does not happen with Firefox. New build auto updated today and it’s still happening. Someone at Brave needs to address this please.

1 Like

For anyone encountering this issue, can you please provide your Brave version (Menu → About Brave) as well as what Operating System you’re using?

1 Like

Hi @mculver could you please provide your Brave version brave://settings/help and your Os as well?

Be waiting for your response.

Okay, I have disabled all the entries in shields (ie security?), but nothing seems to make a difference. Private window changes nothing.

1 Like

Hi again, I kindly suggest you create a new profile or opening a new page using guest mode to see if you are able to load it properly.

Go to the menu > Click on create a new profile > click on the arrow button > Select guest mode or Add to change your profile.

Additionally, could you please provide your Brave version brave://settings/help and your Os as well?

Be waiting for your response.

Hello again,

the version is mentioned in the first posting: v1.44.108. I am on Win10 (latest).

Guest window and new profile don’t change anything I am afraid…

Today I have maybe experienced a different behaviour but I couldn’t doublecheck. I’ll keep you posted.

1 Like

Hello again, did this change happened using a different internet connection when loading the page?

I kindly suggest you change the internet connection your PC has , to see if this helps the first page to load properly.

Regards.

Sorry for replying so late.

I cannot reproduce the issue anymore; Brave loads every page - also the first one - as quickly as it should. I don’t know if our network changed or if it was due to an update.

I’ll get back to you if something changes but thanks a lot for your patience and your help!

1 Like

@dasdas1 glad to read that the issue is no longer present. If you encounter this same issue again or have any other concerns, do not hesitate to let us know.

Regards. :lion:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.