Cannot download files due to insufficient permissions following update

Description of the issue:
How can this issue be reproduced?

  1. Select a file to download from any sessions e.g. Adobe Document Cloud
  2. Click download
  3. Error message “Failed - insufficient permission”

Expected result: file downloaded

Brave Version( check About Brave): latest

Additional Information: The general knowledge base entry on that related topic does not help. This issue happend for a couple of days very likely after an update so it’s a bug.

Did you see any of these other solutions? https://community.brave.com/search?expanded=true&q=insufficient%20permissions

Most likely it’s AV, or permissions on the folder you’re trying to save to. But I suggest reading thru some of those first, it’s unlikely to be a browser bug.

Clearly, it’s a bug. We’ve tried everything from complete reinstall on osx or clear cookies > same problem which never happened before. Download folder are fully accessible. Kindly address that bug causing massive loss of productivity… and forcing us to switch to Chrome…

1 Like

Well, if you’re convinced it’s a bug, maybe you can provide more detail.

What folder are you trying to save to? What are the permissions on that folder? Are you running any security software?

Can anyone else with a mac chime in here and maybe think of what else in the macOS permissioning model might be interfering? There’s filesystem permissions, possibly RBAC, maybe app whitelists, not sure what else.

Hey. I’m having this issue also. Have you worked out the solution?
Thanks

There have been a few cases of this that I remember recently. I know in at least one case it was the user’s security software causing it, the folder had to be whitelisted I think. Short on time right now but I can find the exact thread later if needed.

I believe in one earlier case it may have been folder permissions.

If you’re still stuck I can comb thru other ideas a little later.

Update: here it is. Unable to download anything from this browser - #11 by JimB1

Thanks for the reply. I’ll look into my anti Virus