Unable to download anything from this browser

I can’t download from Brave.

What do you mean?

What are you doing? What’s happening?

What operating system and which version?

Any attempt to download a file gives the following response: “Failed - insufficient permission”.

It’s probably a problem with permissions on the folder you’re trying to save into. Check there first.

There are also some other ideas here: https://www.technipages.com/chrome-download-failed-insufficient-permissions

If you go thru that and still have issues please respond to the earlier questions, thanks.

Hi, I’m getting the same problem. Same as bowieuk, any attempt to download a file gives me “Failed - insufficient permissions.” I can download things just fine on Chrome and Safari. I’m on a Macbook Pro, Big Sur Version 11.6, Brave V.1.31.88. I tried nearly everything on https://www.technipages.com/chrome-download-failed-insufficient-permissions , except for completely reinstalling Brave, which seems really annoying. Any ideas for what else I might try before the nuclear option?

Could it be this? https://www.wikihow.com/Give-System-Permissions-for-Apps-on-MacOS-Catalina

In short, perhaps the app hasn’t been granted access to the filesystem by the OS.

Catalina is earlier version… @Success has Big Sur…

You do realize that features get introduced into operating systems, and then maintained going forward, right? If you’d read past the headline or even the URL string you’d see that. But, the link has no clicks so you apparently didn’t even do that much.

I didn’t want to go down this road, but this is what I was referring to on an earlier post – if you want to help out here, put some work into it vs. just trolling. I don’t have a macOS system to test on, but the impacted user can take a look at the article and decide whether or not this applies. I don’t pretend to know the answer but I’m trying to help. So far I don’t see any other solutions presented, and you’re just wasting everyone’s time here – if you’re certain that this doesn’t apply, please contribute that you’re sure it doesn’t, and why. Otherwise you’re just distracting the affected user from something that could potentially be helpful. I’d rather have the affected user at least check it out, vs. just ignore it because someone else didn’t read past a headline.

Hi @JimB1, thanks for that link. That might very well be the problem. Brave doesn’t have explicit permission for Files and Folders, but neither do any of my other internet browsers. Also, I can’t add anything new to the Files and Folders list. I could add Brave to Full Disk Access, but that seems rather unsafe, right?

Finally, thanks for going to bat against the “trolls”; however, while I completely empathize with the annoyance caused by less than helpful comments, especially when you’re doing your best to help, I think your intended goal might be better effected with a bit of a more gracious rhetoric. We all know the internet is full of trolls, but my hypothesis is that the best way to fend them off is with obsequious kindness. You did an excellent job of providing a logical explanation for what should and should not be here, (and I’m babbling on about being nice) but I thought it might be helpful to offer that people respond to kindness, just as one human to another. And thanks again for looking for a solution for me!

1 Like

:slight_smile: np, and I agree with you. I didn’t really want to respond in that way, it’s just been 3-4x instances of the same sort of thing over the last few days so it was getting old and counterproductive, and now getting to the point where it could potentially hurt those looking for help. But in the end, you’re right.

Regarding the macOS thing, yes I agree, it shouldn’t (or at least, not being a macOS user, it certainly seems that it shouldn’t) be necessary to grant Full Disk Access. I assume these are the settings you were looking at?

Here’s another link but I think it’s essentially the same thing.

I wish Apple made it easier to run VMs and I’d be more than happy to do some testing. Alas, it isn’t really feasible. Maybe someone on a mac can provide a listing of what access their working installation has so it can be compared.

This link has ideas on how to do it with device management and/or 3rd party tools, but again, I don’t see why any of that should be necessary for something this simple.

Here is a video which suggests the issue could be caused by antimalware software installed on the mac. https://www.youtube.com/watch?v=avfEN_8YCog

They show Norton Antivirus in the example, but I suppose the same could occur with other AV software as well.

And, a user here who had the same issue who solved it by fixing the antimalware software: Unable to download - insufficient permissions error - #2 by FEZ


Yes! You solved it! Three cheers for @JimB1!

I currently use Bitdefender V. It has a “Safe Files” feature which blocks access to particular folders. By removing my downloads folder from the list, I solved the problem!

Thanks again you problem solving crusader of the internet wilds!

1 Like

Wait a minute: you yourself dont use macOS and you theoretise about solution(s) for problems users of Brave for Mac face(s)?

What a nerve…